Battery stays on 92%

Hi all,

I am on Bspwm, and I just figured that battery is always on 92%, while my laptop is on charger.

System:
  Kernel: 5.12.9-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-linux 
  root=UUID=574fa5e5-e713-44af-b74e-38874d97dc0d rw quiet loglevel=3 
  nowatchdog 
  Desktop: bspwm 0.9.10 info: polybar vt: 7 dm: LightDM 1.30.0 
  Distro: EndeavourOS base: Arch Linux 
Machine:
  Type: Convertible System: HP product: HP ENVY x360 Convertible 13-ar0xxx 
  v: N/A serial: <filter> Chassis: type: 31 serial: <filter> 
  Mobo: HP model: 85DE v: 41.36 serial: <filter> UEFI: AMI v: F.23 
  date: 02/05/2021 
Battery:
  ID-1: BAT0 charge: 33.3 Wh (93.0%) condition: 35.8/655.4 Wh (5.5%) 
  volts: 17.2 min: 15.4 model: 333-2B-49-A KC04053XL type: Li-ion 
  serial: <filter> status: Unknown 
  Device-1: hid-0018:04F3:23B9.0001-battery model: ELAN2514:00 04F3:23B9 
  serial: N/A charge: N/A status: N/A 
Memory:
  RAM: total: 5.74 GiB used: 1.44 GiB (25.0%) 
  RAM Report: 
  missing: Required tool dmidecode not installed. Check --recommends 
CPU:
  Info: Quad Core model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx 
  bits: 64 type: MT MCP arch: Zen/Zen+ note: check family: 17 (23) 
  model-id: 18 (24) stepping: 1 microcode: 8108109 cache: L2: 2 MiB 
  bogomips: 33550 
  Speed: 2374 MHz min/max: 1400/2100 MHz boost: enabled Core speeds (MHz): 
  1: 2374 2: 2087 3: 1386 4: 1398 5: 1239 6: 1262 7: 1261 8: 1300 
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1 
  bmi2 bpext clflush clflushopt clzero cmov cmp_legacy constant_tsc cpb cpuid 
  cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid 
  fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb irperf lahf_lm lbrv lm mca 
  mce misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nonstop_tsc nopl 
  npt nrip_save nx osvw overflow_recov pae pat pausefilter pclmulqdq pdpe1gb 
  perfctr_core perfctr_llc perfctr_nb pfthreshold pge pni popcnt pse pse36 
  rdrand rdseed rdtscp rep_good sep sev sev_es sha_ni skinit smap smca sme 
  smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 succor svm svm_lock syscall tce 
  topoext tsc tsc_scale v_vmsave_vmload vgif vmcb_clean vme vmmcall wdt 
  xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: AMD Picasso vendor: Hewlett-Packard driver: amdgpu v: kernel 
  bus-ID: 04:00.0 chip-ID: 1002:15d8 class-ID: 0300 
  Device-2: Lite-On HP Wide Vision HD Camera type: USB driver: uvcvideo 
  bus-ID: 3-1:2 chip-ID: 04ca:709d class-ID: 0e02 
  Display: x11 server: X.Org 1.20.11 compositor: picom v: git-dac85 driver: 
  loaded: amdgpu,ati unloaded: fbdev,modesetting,vesa display-ID: :0 
  screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 166 size: 293x165mm (11.5x6.5") 
  diag: 336mm (13.2") 
  Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus-ID: 04:00.1 chip-ID: 1002:15de 
  class-ID: 0403 
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor 
  vendor: Hewlett-Packard driver: snd_pci_acp3x v: kernel 
  alternate: snd_rn_pci_acp3x bus-ID: 04:00.5 chip-ID: 1022:15e2 
  class-ID: 0480 
  Device-3: AMD Family 17h HD Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus-ID: 04:00.6 chip-ID: 1022:15e3 
  class-ID: 0403 
  Sound Server-1: ALSA v: k5.12.9-arch1-1 running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.29 running: no 
Network:
  Device-1: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter 
  vendor: Hewlett-Packard driver: rtw_8822be v: N/A modules: rtw88_8822be 
  port: f000 bus-ID: 02:00.0 chip-ID: 10ec:b822 class-ID: 0280 
  IF: wlan0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
Bluetooth:
  Device-1: Realtek Realtek Bluetooth 4.2 Adapter type: USB driver: btusb 
  v: 0.8 bus-ID: 3-2:3 chip-ID: 0bda:b00b class-ID: e001 serial: <filter> 
  Report: This feature requires one of these tools: hciconfig/bt-adapter 
Logical:
  Permissions: Unable to run lvs. Root privileges required. 
RAID:
  Message: No RAID data was found. 
Drives:
  Local Storage: total: 476.94 GiB used: 6.05 GiB (1.3%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNW512G8H 
  size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 rotation: SSD serial: <filter> rev: HPS0 scheme: GPT 
  Message: No Optical or Floppy data was found. 
Partition:
  ID-1: / raw-size: 232.3 GiB size: 227.59 GiB (97.97%) used: 5.47 GiB (2.4%) 
  fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 label: N/A 
  uuid: 574fa5e5-e713-44af-b74e-38874d97dc0d 
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%) 
  used: 280 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 
  label: NO_LABEL uuid: 5923-E3DE 
  ID-3: /home raw-size: 244.14 GiB size: 239.25 GiB (98.00%) 
  used: 592.6 MiB (0.2%) fs: ext4 dev: /dev/nvme0n1p3 maj-min: 259:3 
  label: N/A uuid: 51946a01-b5a0-4a3a-b65c-091e7f9d024d 
Swap:
  Alert: No Swap data was found. 
Unmounted:
  Message: No Unmounted partitions found. 
USB:
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 1-3:2 info: Xenta 2.4GHz Receiver (Keyboard and Mouse) 
  type: Keyboard,Mouse,HID driver: hid-generic,usbhid interfaces: 3 rev: 1.1 
  speed: 1.5 Mb/s power: 100mA chip-ID: 1d57:32da class-ID: 0300 
  Device-2: 1-4:3 info: Synaptics type: <vendor specific> driver: N/A 
  interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 06cb:00d2 
  class-ID: ff00 serial: <filter> 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 3-1:2 info: Lite-On HP Wide Vision HD Camera type: Video 
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA 
  chip-ID: 04ca:709d class-ID: 0e02 
  Device-2: 3-2:3 info: Realtek Realtek Bluetooth 4.2 Adapter type: Bluetooth 
  driver: btusb interfaces: 2 rev: 1.1 speed: 12 Mb/s power: 500mA 
  chip-ID: 0bda:b00b class-ID: e001 serial: <filter> 
  Hub-4: 4-0:1 info: Full speed (or root) Hub ports: 1 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
Sensors:
  System Temperatures: cpu: 53.5 C mobo: 43.0 C gpu: amdgpu temp: 53.0 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 237 Uptime: 3h 09m wakeups: 3124 Init: systemd v: 248 
  tool: systemctl Compilers: gcc: 11.1.0 Packages: pacman: 772 lib: 203 
  Shell: Bash v: 5.1.8 running-in: xfce4-terminal inxi: 3.3.03

Check your bios, perhaps it has enabled feature which doesn’t overcharge battery against some limit (it’s used to save battery lifespan on some laptops)

condition: 35.8/655.4 Wh (5.5%)

Jeez, i hope it’s reading mistake :sweat_smile:
Otherwise it means your battery is almost dead


Looks like bios / battery for that model is not it’s strongest part…

2 Likes

Wow!
Is this a supermegagigapeta… battery?
:astonished:

3 Likes

I doubt that… because you can check my hardware report before 2 days : http://ix.io/3oFl battery stats :slight_smile:

1 Like

nah, something is wrong I think… check my previous post

1 Like

Well then maybe your hardware is reporting wrong stats?

2 Likes

yes , but why ? :slight_smile: bad install or ? maybe I can change kernel ?

Easiest way to find out - run it from live USB and see if it’s the same behavior

2 Likes

I tried now with zen kernel :

> battery:
>   ID-1: BAT0 charge: 47.7 Wh (93.0%) condition: 51.3/51.3 Wh (100.0%) 
>   volts: 17.5 min: 15.4 model: 333-2B-49-A KC04053XL type: Li-ion 
>   serial: <filter> status: Charging 
>   Device-1: hid-0018:04F3:23B9.0004-battery model: ELAN2514:00 04F3:23B9 
>   serial: N/A charge: N/A status: N/A

seems good now…weird

3 Likes

Then report this to Kernel maintainers if it’s not known, and use LTS / zen :upside_down_face:

2 Likes

So is the problem solved then?
I found that on my laptop (MSI) the only way to change the battery max charge limit is through the manufacturer provided windows utility. No setting in BIOS (even when I activate the hidden settings). I have to dual boot in Windows, change the setting and then get back to doing my work in Linux, where the changes done in Window to the battery charging behaviour persist.

Yes, it is solved… I tried different kernel and everything is fine now :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.