Battery charge max is lower & strange cant change power button behavour?

  1. New laptop , always plugged in, battery Power max charge in Windows and Endeavour was always at 94% initially. Then after being on battery for a while (not plugged in charge), (I was trying to see how long the battery could last.) anyhow after power dropped after few hours to 25% I plugged the power charger in and the battery gradually charged to max 78/79% and stays at 78% now , not 94% as before? Is that normal?

also the power menu says “not charging” is this OK? because in Ubuntu usually it says “Fully Charged” instead? I dont understand how the max charge suddenly changed now?

If the lowered max charge of 78% is normal then how to change max charge back to say >80% if I wanted a higher max charge?

  1. In Settings-power-powerbuttonbehaviour It is always on “suspend”? When I change the variable to “power off” after i quit the menu and go back it always somehow reverts itself to “suspend” again? I cant chane power button behaviour to "Power off " at all? Where as in Ubuntu I can . Is this a bug (or a “feature” )?

side note:
3) Super-L key doesnt work. My Super-K key seems to not activate, and I can see my Fn key seems to be set as my Super-L key? Any other same issue?

luvin Endeavour btw. Great work.

(Gnome installation of EndeavourOS_Artemis_neo_22_8 on Ryzen 7 5700U MSI laptop)

  1. power setting solved using tlp settings, TLP works well in my non Thinkpad laptop,
  2. Super-L button not working still not fixed yet. Hope will get resolved in later updates.

Problem is not solved as I expected. After my battery charged to 85 it still reverted back to 79% after a few days so I still can’t change the threshold stop charging battery setting.

I use tlpui to do charging thresholds.

This is my stats tlp battery. am not familiar with tlp. Does this mean I have only BAT1 because I see in tlpui I have BAT0 and BAT1 settings?
Screenshot from 2022-09-19 12-29-19

This my tlpui . i set to 83% max like this? is BAT0
setting necessary?
In wiki arch I saw this "/etc/tp-battery-mode.conf

STOP_THRESHOLD=90" but I cant find the /etc/tp-battery-mode.conf file so thats why I tried tlpui instead.

And if tlp is not supported in my MSI laptop then is there a bash command to set or change max batter charge in endeavouros directly from terminal? tia

if i now run
sudo tlp-stat --battery

I get this
Screenshot from 2022-09-19 12-56-24
seems no change?

battery icon same always 79%
and if i run
sudo tlp fullcharge BAT1 ##same for BAT0
I get
Error: battery charge thresholds not available.

IS there any solution? I rebooted few times same thing reverts back to 79% max charge still cant change it.

Hard to say what the solution is without knowing much about your device.
If I were in your shoes I would

  • unplug the device
  • reboot into bios and load setup defaults
  • reboot directly to live iso without booting to your current installation
  • plug in the charger and wait to see if it charges past 80%

Could you also provide the exact model of your laptop

My laptop is MSI modern 14 B5M (9S7-14DL24-068) Ryzen 7 5700 U, 16Gb RAM, 512Gb nvme ssd. (Battery 3cell 39Whr)

When you say “reboot into bios and load setup defaults” , do you mean reset the BIOS to default settings before booting a live Endeavour usb?

BTW can I ask what is the default max battery charge setting for endeavoros?

Yes, that’s what I would try. I think that way we could determine whether it’s a problem with your installation by eliminating it as a variable. You can also just boot into a live iso first without resetting the bios to see if that has any effect.

EndeavourOS doesn’t limit charge capacity by default.

1 Like
  1. So I rebooted into live ISO as suggested. And the problem is the same in the live ISO ,and after booting into my own EOS. ie Battery still wont charge past 80%. Can’t change max battery stop or start charge. I tried setting via tlpui to no effect. I also tried slimbookbattery and no effect. My BIOS has no battery charge options at all.

Anyhow I did some searching around online I found a user (nate-x) similar problem with MSI and arch-based Manjaro (he was trying to change battery max charge lower from 100 to 80 but could not change setting also apparently)

he “solved” it, only way was to boot into Windows and install the MSI Creator Center (the dedicated Windows App for this model)… set the battery option to stop charging at (desired)X% and start charging at say Y% then rebooted into Linux. ie…Only solution is to involve Windows…it was marked as “solution”

I read somewhere else that the battery levels could be hardcoded into the motherboard during Windows install process or via the MSI Creator Centre app? At the moment this seems to be the only solution, to set it via Windows, unless someone found another way to do it via linux.

  1. The Power button behavior in Power-settings cannot be changed from Suspend to Power-off still. I guess this is a small bug. If I set it to Poweroff it just reverts back to suspend when you close the window. (not solved)

3)Super-L key still not working and I am told by some KDE EOS users it is a bug. The Super-L key is by default the Fn key for EOS on MSI Modern 14. Just takes getting used to until it has been fixed by an update. (not solved)