Bash-completion doesn't allow bash to expand wildcards

Hi there, I’m new to EndeavourOS.

I’m used to doing things like this in the terminal

$ okular *pdf
$ okular a.pdf
$ okular b.pdf

but in my newly installed EndeavourOS that didn’t work out of the box. So I started reading what could be happening and found out that bash-completion is preventing bash from doing the expansion. I learned that I could add the line

shopt -u progcomp

to disable bash-completion. But then I’m thinking I should just remove the package. Which makes me wonder, why does EndeavourOS come with bash-completion pre-installed in the first place?

I can see the value in auto-completing pacman packages, for instance, when writing pacman -S terminus<TAB>, but I much more commonly use the former feature. Is it just me that prefers wildcard expansion over pacman package completion and the like?

I read over here that one can get both features if the complete command is run with the parameter -o bashdefault instead of -o default when bash-completion is setting up. They say one should edit /etc/bash_completion to change that but my system has no such file. Does anyone know where one could make such a change?