Badly rendered splash screen on Razer Blade 15 Adbvanced 2018

Hi All,

I am using EndeavourOS on a “Razer Blade 15 Advanced, 2018” without any significant problem, and I like it very much except the boot screen rendering, which looks a bit ugly:

TO SEE THE SCREENSHOT CLICK HERE!

This screen appears for less than a second after I entering my password on the login screen and after this splash screen the screen rendering is anyway fine.

Any idea how to fix it?
My parameters:

xxx@xxx
Kernel: x86_64 Linux 5.11.11-arch1-1
Packages: 881
Shell: bash 5.1.4
WM: Xfwm4
GTK Theme: Arc-Darker [GTK2]
Icon Theme: Arc-X-D
Disk: 16G / 104G (16%)
RAM: 2320MiB / 15902MiB
xxx@xxx
Uptime: 2h 9m
DE: Xfce4
GPU: GeForce GTX 1060 Mobile
WM Theme: Arc-Darker
CPU: Intel Core i7-8750H @ 12x 4.1GHz [40.0°C]
OS: EndeavourOS rolling rolling
Resolution: 1920x1080

you can set gfx resolution for grub: /etc/default/grub

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=auto

change it to your screen resolution:

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=1920x1080

then regenerate grub:
sudo grub-mkconfig -o /boot/grub/grub.cfg

Hi joekamparad,

First of all thanks for your suggestion, that improved the GRUB loader’s screen to a lot better, but after I entering my password a badly rendered screen still flashes, and then the system loads perfectly with XFCE.
This is what I see, pls. click on the link.
Any idea?

this is lightdm then and not boot screen :nerd_face:
currently there are several issues with Nvidia Driver caused by changes on Mesa as far as we can see.
You could try this the troubleshooting part:

It can also help to use a display setup script for lightdm like you can see in the video for multidisplay setups, what will work the same for single display:

Setup LightDM to work nicely on Multidisplay systems

1 Like

I checked the first part by setting

logind-check-graphical=true

then restarted lightdm to see if it is working:

`sudo systemctl restart lightdm`

It worked, but I did a complete reboot and it still appears.
Then I continued with the debugging part by installing Xephyr

sudo pacman -S xorg-server-xephyr

Unfortunately with CTRL+SHIFT I could not take over in the guest window the cusror and the keyboard, then closed that.
It should work according to: https://wiki.archlinux.org/index.php/Xephyr#Installation, but it doesn’t work! Therefore I could not debug it.

Finally tried:

systemctl status lightdm

The output is the following:


This seems like an existing, not yet solved error on arch:
https://gitlab.gnome.org/GNOME/gnome-keyring/-/issues/28
Any idea?

i do not think that the pam warnings are related to your issue.

Did you try using the display setup script already?

Yes, I did that as well as it is described in points 1 - 7. That did not help.

The only thing that helps is if I wait a few minutes to click on the OK button or press Enter (I don’t know exactly how many) at the login screen after entering my password. In that case that badly rendered screen did not appear at all.

Only way I have gotten that gkr-pam error to go away was to uninstall gnome-keyring. It’s more complicated now because it is a dependency of seahorse. I am in no way recommending you do this. :stop_sign:

Just adding to the conversation.

I read the tutorial more carefully and by having the symptom that I described here it is almost like a timing issue with the driver loading…

There are several different cases where Lightdm can fail to start, mostly it is the case if the GPU driver is not loading at all or too late. what makes the X system fail to be available for lightdm.

If I could debug it that would be better, but I cannot take the cursor and the keyboard with CTRL+SHIFT in the debug window.

Gent’s would you have any idea how could I improve this part of Endeavouros?

Is this a Hybrid Intel Nvidia laptop? Do you have it setup with Optimus?

Hi ricklinux,
Thanks for your reply. I use Intel graphics only to save power, so the NVIDIA GPU is completely powered off. At least I assume that :slight_smile:

Do you have early KMS setup? also on hybrid laptops graphics can be a pain but if you boot with intel as the primary using early KMS it might help but idk

No, I don’t have that setup and it seems too challenging for me…

use the guide here, its fairly simple to do https://wiki.archlinux.org/index.php/Kernel_mode_setting#Early_KMS_start

I was asking if you have it set up with Optimus or how do you have it set up? How do you have Nvidia turned off in the Bios?

Thanks for all your helping approaches. Well, this is what I can see using the “lspci -v” command:

00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 630 (Mobile) (prog-if 00 [VGA controller])
	DeviceName: Onboard - Video
	Subsystem: Razer USA Ltd. Device 2000
	Flags: bus master, fast devsel, latency 0, IRQ 147
	Memory at ab000000 (64-bit, non-prefetchable) [size=16M]
	Memory at 40000000 (64-bit, prefetchable) [size=256M]
	I/O ports at 4000 [size=64]
	Expansion ROM at 000c0000 [virtual] [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel driver in use: i915
	Kernel modules: i915
01:00.0 VGA compatible controller: NVIDIA Corporation GP106M [GeForce GTX 1060 Mobile] (rev a1) (prog-if 00 [VGA controller])
	Subsystem: Razer USA Ltd. Device 2000
	Flags: bus master, fast devsel, latency 0, IRQ 148
	Memory at ac000000 (32-bit, non-prefetchable) [size=16M]
	Memory at 80000000 (64-bit, prefetchable) [size=256M]
	Memory at 90000000 (64-bit, prefetchable) [size=32M]
	I/O ports at 3000 [size=128]
	Expansion ROM at ad000000 [disabled] [size=512K]
	Capabilities: <access denied>
	Kernel driver in use: nouveau
	Kernel modules: nouveau

I did not turned the NVIDIA card off in BIOS, I just simply not yet installed its drivers (however I cannot exclude, that Endeavouros didn’t do that in the meantime. How could I determine that properly, anyway?

the opensource one is inside kernel also (modesetting driver) so it could be used if not configured to blacklisting it, or disable discrete gpu in Bios/Firmware

Where should I start with the hybrid installation to be able to switch between the NVIDIA and the Intel drivers?
This is my system from the hardware point of view:

[xxx@blade ~]$ lspci -vnn | grep '\''[030[02]\]'
00:02.0 VGA compatible controller [0300]: Intel Corporation UHD Graphics 630 (Mobile) [8086:3e9b] (prog-if 00 [VGA controller])
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GP106M [GeForce GTX 1060 Mobile] [10de:1c20] (rev a1) (prog-if 00 [VGA controller])

Screenshot_2021-04-04_18-19-08

The proprietary Nvidia Driver can have render offload included already, what can be used to switch… or you can install and configure Optimus-manager (or any other switcher tool):