Bad laptop shutdown

I have an HP laptop with a ryzen 5 U and vega 8. When I turn it off, the battery keeps draining. The only solution found, thanks to Beuz from mageia-discuss-fr is, after turning it off, to physically turn it off by a long press on the on-off button.
A zen-ck core doesn’t change the problem.

I’m not sure how to know what remains active after a normal shutdown.

Any idea ?

journalctl -b 1



As a first step and with all due respect, if you are not too wet with the ck type kernel, as a tip do not use it, as it is not the Arch/Eos standard. Besides, this type of kernel makes the user to be very much on top of it, always. It is not simple.

262. [    0.605323] NMI watchdog: Enabled. Permanently consumes one hw-PMU counter.

427. [    0.780128] ACPI FADT declares the system doesn't support PCIe ASPM, so disable it

1644.févr. 04 23:17:05 hpasaln kernel: ACPI FADT declares the system doesn't support PCIe ASPM, so disable it

1669.févr. 04 23:17:05 hpasaln kernel: PCI: Using host bridge windows from ACPI; if necessary, use "pci=nocrs" and report a bug

2380.févr. 04 23:17:07 hpasaln kernel: EDAC amd64: Node 0: DRAM ECC disabled.

2381.févr. 04 23:17:07 hpasaln kernel: EDAC amd64: ECC disabled in the BIOS or no ECC capability, module will not load.
                                    Either enable ECC checking or force module loading by setting 'ecc_enable_override'.
                                    (Note that use of the override may cause unknown side effects.)

I’m sorry.
But I only installed this kernel after I noticed this problem with the default installation.
However here are the same logs with the 5.5.2-arch1-1 kernel.

I will see in one or two hours if this update has fixed the problem.

2% loss between one and two hours of downtime

inxi -Fcxxx0
acpi -V
inxi -B


If you want, you could try putting these commands on the kernel line, in grub, like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet loglevel=3 pci=noaer pcie_aspm=off"

You probably have “quiet loglevel=3”, put the following 2: pci=noaer pcie_aspm=off"`

Remember to update grub with: sudo grub-mkconfig -o /boot/grub/grub.cfg

Then it restarts.

Just an idea in case it doesn’t get any easier. :slight_smile:

Add to .bashrc - .zshrc …

alias update-grub='sudo grub-mkconfig -o /boot/grub/grub.cfg'

All that data looks good !
Also the machine is new and the bios is updated. By the way, check if there are any new updates, just in case, of BIOS

Added the above parameters to the grub :question:
Is this problem only for Linux or was it the same for Windows ?

It is really very rare, but I also see that the hardware, in my opinion, has no problems …

I will still keep an eye on any possible solution and let you know. :slight_smile:

1 Like

No new update of the bios for the moment and this problem does not occur under Windows.
I’ve added the new settings to grub. But it doesn’t seem to change anything : 3% loss in 1h30min. So I’ll keep on pressing the button :wink:

Anyway thanks for your suggestions and help!

You have tried removing the battery and then pressing the power button for about 20 seconds and then putting the battery back in and turning the system on.

Now, I don’t know if you can take the battery out of your machine, in some cases you can’t … ?

On this pc the battery is not removable.

I don’t see that those figures are wrong, it seems logical to me with the hardware you have, it consumes quite a lot of battery, it’s my opinion only …

Edit: bad me, of course off …

I understand :frowning:

Hello @Asaln
Are you using wireless connection? Check your Uefi Bios settings and make sure WOL is turned off. (Wake On Lan) Sometimes even though it’s turned off in Bios on Arch it’s still runs so you need to use ethtool and disable it for you wifi.

1 Like