Automatically hdd deleted my files

HEY! I am not here for ext4magic or other recovery tool, I am here for want to know why it got deleted? yesterday i’ve added few things to the fstab such as ( options ) but i dont thing it will delete eveything form my HDD, Another thing i’ve did is mounting drive in /mnt does it has anything to do with this? Right now every drive got formated on my HDD.

1 Like

I doubt anything is deleted from editing fstab probably just messed up in your entrys. Install your backup of fstab and do one drive at time to see if it is in fact and fstab entry issue or another issue.

i’ve tested that with gpared and i’ve found all disk partitions got formarted, also i’ve tried pop os ISO to see if anything is there or not.

try running testdisk and see if it gets your partitions back

1 Like

okay it worked for ext4 not btrfs, anyways that ext4 drive had many photos as a backup but ive found thing in there expect i’ve added a pendrive backup after that happend, right now i am thinking about what happended!! i dont care about my backup but i want to know why this happend to me.

1 Like

Review your journal log. Unless your HDD is failing (which is possible) this will tell you what your ran to delete stuff.

If it truly is random and you didn’t do anything, there’s likely no way we’ll be able to figure out why.

The answer is easy and obvious. It seems you haven’t understood well about how mounting works in Linux.

I suggest you spend some time reading about it, so you won’t get frustrated. It is not rocket science, while wrong decisions can lead to serious data loss.

are you sure about that? clear - i’ve checked with gparted and there is nothing expect few pre loaded size for folder, And i am sure that it dont happend form me because every partions can’t get formarted.

( i am not good at english so you can think i am noob ) but i am not dude…

You may have misunderstood me… dude (I don’t know what this word means. Is it cursing? It’s all Greek to me :smile: ).

The above statement made me think what I wrote. Am I wrong?

A disk partitioning operation will never happen during boot sequence, unless the System Administrator has developed and configured this to happen.

what a joke btw xd, anyways

somehow yes, if i formart anything then why i am going to do with every drive? btw i am on artix linux not EOS.

just i’ve remembered that i’ve deleted /media/* folder when i was going something SHIT. anyways thanks for EOS people’s help.

So let me get this right.

You are upset because you think artix automatically deleted something off your HDD so you came to the Endeavour forum to ask why and complain about it and are now mad because people basically told you it’s not possible without causing the issue yourself and you forgot you deleted something?

Love it.

yes i used artix but i came here for /etc/fstab not for artix, And btw artix has some toxic peoples.

If you can delete this useless post.

but this isn’t and fstab issue.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.