AUR jitsi install error in build()

I am trying to install this AUR repository of jitsi (it is the one recommended by jitsi website)

At the end of a very long terminal output here’s what I get:

[sherabk@EndevourOS jitsi]$ makepkg -si > ~/jitsi.output 
    5633.tar.gz ... Passed
    jitsi.desktop ... Passed ... Passed

/home/sherabk/AUR/jitsi/src/jitsi-5633/build.xml:269: Compile failed; see the compiler error output for details.

Total time: 16 seconds
==> ERROR: A failure occurred in build().

The above is deducted - for the full output see file attached
edit :slightly_smiling_face:
How do you upload a .txt file?

output on pastebin here

1 Like

Not a solution for your problem - but you could try using jitsi-meet-desktop-bin

$ yay -Ss jitsi-meet-desktop-bin
aur/jitsi-meet-desktop-bin 2021.12.1-1 (+32 0.98) (Installed: 2021.11.2-1)
    Jitsi Meet desktop application powered by Electron

for normal usage i would recommend using web interface:

1 Like

Thank you

@EndevourOS ~]$ yay -Ss jitsi-meet-desktop-bin
aur/jitsi-meet-desktop-bin 2021.12.1-1 (+32 0.98) 
    Jitsi Meet desktop application powered by Electron

It does not seem to install anything??

Thank you I worked it out…

git clone
cd jitsi-etc
makepkg -si

it works now

-Ss searches only to install/build withyay use without options to choose from one or if you know exact name use yay -S jitsi-meet-desktop-bin :wink:


I can’t replicate here using a clean chroot (i.e. it builds OK for me using makechrootpkg), so either it’s an issue with using yay and picking up something else that’s installed (e.g. a different software version) or you’re running out of disk space or RAM during compilation.

I done it this way:

git clone the repo
cd to the repo
makepkg -si

So maybe I should have used the makechrootpkg like you did??

1 Like

Hmm… makepkg is pretty reliable (why did I think you used yay? Maybe I was reading another thread at the same time…).

But, it can still end up picking up the wrong set of libraries (or wrong Java version) from your system, so if you want to, trying makechrootpkg could be interesting.

there was indeed a mention of yay -Ss
but only after my first post where I used makepkg -si
ok I have installed it now as I show in the above post
thank you for your help

1 Like