Audio comes and goes, on and off

Dear all,

I have persistently installed Endeavour OS with i3wm in a USB stick and I start my laptop from it.

Everything seems good except the audio. When I play a youtube video or play some mp3 file, there’s no sound, then suddenly there’s sound for a few seconds, then it’s gone again, and it seems to be like that in a loop.

I had this issue with Manjaro XFCE installed but not with Manjaro i3, both installed the same way.

Maybe this helps:

Since the issue doesn’t happen with Manjaro i3, is it possible that I log into it and somehow see what is different there in the sourd configuration with regards to my installation of Endeavour OS (so as to know what needs to be tweaked or where the problem is)?

Thanks in advance.

Cheers, Manuel

Welcome to EOS! :wave: Are you using Pipewire for audio? Check and see if it is installed.

It has issues with Firefox videos/audio and other applications and the result is exactly the issue you described. The theory is that when two or more audio sources play at the same time, it freaks out and mutes. Some blame Firefox, but I have had it happen with other applications also. The solution is to remove Pipewire and switch to Pulse Audio…and let Pipewire bake in the oven a bit longer.


Welcome @msoutopico

1 Like

Dear Rodney,

Sorry that it took me a bit long, I wasn’t using my eOS machine during the summer.

I have this problem in Skype.

I have tried to uninstall pipewire but it seems to have some dependencies (e.g. telegram!), and I’m unsure about how to proceed.

This is what I get:

[pico@zen] $ sudo pacman -R pipewire
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing pipewire breaks dependency '' required by gst-plugin-pipewire
:: removing pipewire breaks dependency 'pipewire' required by pipewire-media-session
:: removing pipewire breaks dependency '' required by pipewire-media-session
:: removing pipewire breaks dependency 'pipewire' required by telegram-desktop

Any tips?
Thanks in advance.

Cheers, Manuel

1 Like

Would be helpful to see the hardware info.

inxi -Faz --no-host | eos-sendlog

Edit: You are running on alsa and pulse audio.
Pipewire has files installed but is not running on pipewire.

Try installing pipewire it will replace pulse.

sudo pacman -S pipewire pipewire-pulse --needed

From the post directly before yours…

I have done the conversion from Pulse Audio to Pipewire and back to Pulse Audio several times. The best way to handle it is to just install the Pulse Audio packages. Pacman should handle the dependencies without breaking anything.

sudo pacman -Sy pulseaudio pulseaudio-bluetooth

When you run the above command, you will be told that the piperwire-pulse and pipewire-alsa (if installed) conflict with the packages you are trying to install. You do not really need to uninstall the pipewire package itself. The pipewire service will not run unless it is activated. The pulseaudio service should be set to run on reboot when you install it.

Once you reboot, check to make sure that the Pulse Audio service is running, open a terminal and type:

pactl info

This will tell you what sound service you are running. If the Pulse Audio service is not running, start it by typing the following in the terminal:

systemctl start pulseaudio.service pulseaudio.socket

Check to make sure it is running properly. If it is, permanently enable the Pulse Audio services by typing:

systemctl enable pulseaudio.service pulseaudio.socket

Pulse Audio will not run on boot.

I hope this helps.

Ya … i read where the OP said they have tried to uninstall pipewire. I was just looking at the fact that it wasn’t running pipewire. So maybe it wasn’t really working to begin with. A few others have had issues with audio and installing pipewire resolved it. Mine is running pulse on pipewire as i switched all of mine. As long as the audio works it doesn’t really matter to me if it use pulse or pipewire. Is pipewire replacing pulse eventually? Seems like there are constant updates to it. :man_shrugging:

Hello Manuel,

If you are still trying to uninstall pipewire, I believe you will need to uninstall those dependencies first, then try uninstalling pipewire itself. There use to be a package called ‘pulseaudio-lecacy’ which you would have needed, but I think that has recently morphed into just ‘pulseaudio.’

With that said, Pipewire has made a lot of improvements, tons of updates since your post, and now works well with Firefox and other apps. You might want to make sure you have Pipewire fully installed, and give it ago again.

As @ricklinux pointed out;

sudo pacman -S pipewire pipewire-pulse

Hope that helps.
Best, Rodney