ASUS X515EAX Screenlock Broken [SOLVED]

Waking from sleep I am greeted just by a blinking underline ( _ ). Pressing any key There’s a message stating that the screenlocker is broken, to switch to a console and to type loginctl unclock-session 2.
If I switch to a console there’s just text scrolling, I cannot type anything. REISUB is the only way out.

I must add that when I first installed EndeavourOS, at boot time I saw a message stating that splitlock was causing a kernel crash. Googling this I found a recomendation to add this boot parameter split_lock_detect=off
Since I had selected the btrfs filesystem, I looked for ways to include this boot parameter. None of the suggestions to add this parameter worked. So I re-installed, using GRUB because I knew that I could do that in GRUB, so I added this to /etc/default/grub : split_lock_detect=off
The message about splitlock crashing the kernel was replaced by, splitlock off.
I also selected XFS for the filesystem.

So GRUB is still useful

My inxi below:

  Kernel: 6.2.8-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    Desktop: KDE Plasma v: 5.27.3 tk: Qt v: 5.15.8 wm: kwin_wayland dm: SDDM
    Distro: EndeavourOS base: Arch Linux
  Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X515EA_X515EA
    v: 1.0 serial: <superuser required>
  Mobo: ASUSTeK model: X515EA v: 1.0 serial: <superuser required>
    UEFI: American Megatrends LLC. v: X515EA.309 date: 05/16/2022
  ID-1: BAT0 charge: 37.6 Wh (100.0%) condition: 37.6/37.1 Wh (101.2%)
    volts: 7.8 min: 7.8 model: ASUSTeK ASUS Battery serial: N/A
    status: not charging
  Info: quad core model: 11th Gen Intel Core i5-1135G7 bits: 64 type: MT MCP
    arch: Tiger Lake rev: 1 cache: L1: 320 KiB L2: 5 MiB L3: 8 MiB
  Speed (MHz): avg: 2400 min/max: 400/4200 cores: 1: 2400 2: 2400 3: 2400
    4: 2400 5: 2400 6: 2400 7: 2400 8: 2400 bogomips: 38720
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: ASUSTeK
    driver: i915 v: kernel arch: Gen-12.1 ports: active: eDP-1
    empty: DP-1,HDMI-A-1 bus-ID: 0000:00:02.0 chip-ID: 8086:9a49
  Device-2: Sonix USB2.0 HD UVC WebCam type: USB driver: uvcvideo
    bus-ID: 1-3:2 chip-ID: 322e:2103
  Display: wayland server: v: with: Xwayland v: 23.1.0
    compositor: kwin_wayland driver: X: loaded: modesetting
    alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: 0
  Monitor-1: eDP-1 res: 1536x864 size: N/A
  API: OpenGL v: 4.6 Mesa 23.0.0 renderer: Mesa Intel Xe Graphics (TGL GT2)
    direct-render: Yes
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 0000:00:1f.3 chip-ID: 8086:a0c8
  Sound API: ALSA v: k6.2.8-arch1-1 running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.67 running: yes
  Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
    vendor: AzureWave driver: rtw_8821ce v: N/A port: 3000 bus-ID: 0000:02:00.0
    chip-ID: 10ec:c821
  IF: wlan0 state: up mac: <filter>
  Device-1: IMC Networks Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 1-10:3 chip-ID: 13d3:3557
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: see --recommends
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
    v: 0.6 bus-ID: 0000:00:0e.0 chip-ID: 8086:9a0b
  Local Storage: total: 476.94 GiB used: 73.02 GiB (15.3%)
  ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKNU512GZ size: 476.94 GiB
    speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 27.9 C
  ID-1: / size: 466.93 GiB used: 73.02 GiB (15.6%) fs: xfs dev: /dev/dm-0
    mapped: luks-ed478b80-30f4-4d41-bd9c-482d7488d144
  ID-2: /boot/efi size: 998 MiB used: 472 KiB (0.0%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/dm-1 mapped: luks-c7f87df8-3580-49ed-89c3-ae0b6a3d9249
  System Temperatures: cpu: 39.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 2400
  Processes: 228 Uptime: 54m Memory: 7.46 GiB used: 3.01 GiB (40.4%)
  Init: systemd v: 253 default: graphical Compilers: gcc: 12.2.1 Packages:
  pm: pacman pkgs: 1240 Shell: Bash v: 5.1.16 running-in: konsole inxi: 3.3.25

That’s all folks :sweat_smile:
Adding this parameter mem_sleep_default=deep to GRUB has fixed the issue.