Artifacts running an old game, failing to use dxvk

Trying to run this game with lutris: using lutris-GE-proton8-14 but get artifacts like on the screen like on the screnshot. The artifacts like these are only present trying to run this game, other applications and games run fine.

It doesn’t seem that the game uses vulkan no matter what I put in the settings and there are some gstreamer errors.

Game runtime log:
Installed gstreamer packages:
System information:

Is it DIrectX 7-8?
Try to run it with dgvoodoo2 in DirectX mode

  1. Put it where the game .exe is

  2. Run it’s config to configure

  3. Run game to check if it works (there should be dgvoodoo logo in the corner of the screen)

  4. If it works and there’s no artifacts - launch dgvoodoo config again and turn off watermark option

  5. Play

Just so you know you are rendering on amd graphics.

API: OpenGL v: 4.6 Mesa 23.3.0-devel (git-2ae94b3894) renderer: AMD
    Radeon Graphics (raphael_mendocino LLVM 16.0.6 DRM 3.54 6.5.3-arch1-1)

For AMD graphics users:

  • Try disable AMD Virtual Super Resolution:
    I) Open AMD Radeon Settings
    II) Select Screen tab.
    III) Find Virtual Super Resolution option and disable it.

I have tried it with lutris config, now I have tried it manually (disabled in lutris), artifacts remain and I do not see a logo.
I can make the game work with LIBGL_ALWAYS_SOFTWARE=1 but it spins my cpu too much.

I am aware that I am running xorg on amd igpu.
I have tried forcing nvidia gpu for this game with no success; FSR is disabled in the lutris settings and probably overall as I do not seem to have AMD Radeon Settings installed.

Don’t remove dgvoodoo2 yet, we’ll try to make it work.
Can you share that from directory where your game’s exe is?

ls -lA

You should still probably always do that.

Here is the output:

You should still probably always do that.

I do that on all the games but this one is the only one I have such problems with.

hmm…That’s weird, no obvious hooks to override :thinking:

Try to force different DirectX versions from dgvoodoo2 settings, try 11, 10 and 9 in that order to see if one of them will work

Interesting, there’s also similar artifacts related bug reported and fixed in 8.6 ( i assume it should be included in GE-proton 8.14, but maybe try just pure wine, specifically 8.6, to see if it behaves better.

Also Proton-7.1-GE-2 reported to behave great.

I have tried lutris-7.2.2 and lutris-fshack-7.2 to no result.

The only available dgvoodoo dx options for me are DX11. If I try to force nvidia, then it shows (unavailable).

Could it be something with gstreamer in the end, as seen from the logs?
But what could be done with it?

Nah…dxvk doesn’t seem to work.
btw, with wine versions prior to 8.0+ - you have to use dxvk versions before v2.0+ otherwise it won’t work at all.

Also i find that lutris wine versions ain’t best ones, i prefer pure one or staging myself…

I have tried the system wine 8.16 and while there are less errors, there are still gstreamer errors:

Artifacts do seem to change slightly if I use 7.2 wine but basically it is the same thing.

So I can only thing it is actually gstreamer problem but what can I do with that?
I already have the plugins installed.

I can run it in gamescope, it seems to default to software rendering, which is fine to me but how to limit framerate?
It goes around 999 fps which spins cpu too much, limiting framerate through gamescope doesn’t work.

I don’t know, but doubt it has anything to do with artifacts.

Usually for older directx games forcing it through dgvoodoo is your best chance

After reinstalling lib32-nvidia-utils, I have managed to get it running with 60 fps limit forcing amdgpu. It still seems to be running in software but it doesn’t take much cpu so I would say it is solved for me, though I don’t think I can replicate the way I managed to get it running.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.