Artemis Neo Installer hangs at 87%

Endeavour Artemis Neo is consistently hanging at 87% where it runs the eos server selection. Computer is a Chromebox which has no problems booting and installing other distributions. Only Endeavouros seems to hang recently.

Finally on one install it did complete and I am typing from it now; However, I tried many things so I cannot specifically state what I did on which attempt to get it installed.

I am using the r8189 chipset and toggle back and forth to see what works. Both seem to do the job. Don’t know if issue is related to this.

Chromebox has very generic hardware–nothing exotic.

Hopefully, this is a passing phenomenon and not an error here to stay.

Am enjoying the Endeavouros experience so far.

Thank you…

You may have just had a mirror issue. You could post the install log here for the devs to look at possibly. You can do that from the Welcome screen and post the link. Make sure you check off what’s needed to get the proper logs.

Edit: I have a Chromebook i wouldn’t mind installing on also. What is the procedure you used? I might try it someday.

Welcome to the forum! :smile:

Not sure which ISO you are referring, but it is advisable to always use the latest ISO (Artemis nova) on new installs.

See this: https://endeavouros.com/latest-release

1 Like

Downloaded the latest iso just yesterday. So no outdated images used.

Thanks…

1 Like

Ricklinux

Use mrchromebox’ firmware updater and follow the steps. It’s really easy and they make great desktops. You have to open up the unit and remove a screw then put the unit into developer mode.

OFF topic

We’ve got two ChromeOS devices as well (one book and one box) with quite respectable specs which I believe can run any OS quite smoothly. I have also plans, though on a rather low priority side, to replace the OS on at least one of them.

I think here is the start point:

https://wiki.archlinux.org/title/Chrome_OS_devices/Custom_firmware

Also see if your device is supported:

https://wiki.mrchromebox.tech/Supported_Devices

Installation hangs at 87%. When I toggle the command line view it shows the following where the installation stops:

2022-10-13 - 19:58:26 [6]: [PYTHON JOB]: “:: Running post-transaction hooks…\n”
2022-10-13 - 19:58:26 [6]: [PYTHON JOB]: “(1/1) Arming ConditionNeedsUpdate…\n”

2022-10-13 - 19:58:26 [6]: [PYTHON JOB]: “==> info: removing file /etc/resolv.conf.pacnew\n”

2022-10-13 - 19:58:26 [6]: [PYTHON JOB]: “==> info: running /usr/bin/eos-select-file-server\n”

On the installer, after it hangs, can you show the URL from the output of command:

cat ~/endeavour-install.log | eos-sendlog

$ cat ~/endeavour-install.log | eos-sendlog
cat: /home/liveuser/endeavour-install.log: No such file or directory
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 453 100 313 100 140 1150 514 --:–:-- --:–:-- --:–:-- 1671
<!doctype html>Error: not string - clbin: command line pastebin

not string



[liveuser@eos-2022.09.10 ~]$ cat ~/endeavour-install.log | eos-sendlog
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 98699 100 24 100 98675 37 152k --:–:-- --:–:-- --:–:-- 152k
https://clbin.com/xsfwX

can you show the output of df

looks like system runs out of memory…

what are your system specs? What is your RAM. Can you post

inxi -Fxxc0z --no-host | eos-sendlog

128GB SSD 4GB RAM. No other distribution gives me this problem. Until recently even Endeavouros did not do this. Other rolling releases work just fine. It takes about 5-8 tries to get EndeavourOS Artemis latest edition installed. Each time it is 50-50% that it gets past 87% mark and finishes the installation.

It shouldn’t be running out of room as all other distros work fine. This is a sporadic issue on the latest installer. I will probably have to use another distro until a new EndeavourOS installer comes out.

I am no longer on that computer today so I cannot supply you with df output or any output today.

Thanks for you willingness to help. The installer just doesn’t work.

Thank you…