Artemis Live USB Freezes on fontconfig updateing

Cheers Guys,

tried to Install latest Artemis on my Virtualbox.
I always get stuck on 37% Updating fontconfig configuration and the whole System freezes.
If i do a sudo pacman -Syu before (with updates mirrors) the system also freezes.
Any ideas?

Welcome to the forum!

It would be helpful if you could share the output of inxi -Fxxxz so we could see what hardware you have.

I would also recommend testing your memory.

and the settings used for the box would be interesting too.
in addition

is a bad idea on the live session. Never needs to be done and will cause only issues. As it could break lib versions for needed stuff from installer.

means the host or the box?

Welcome to the forum @neuromancer :enos: :enos_flag: :partying_face:

The Livesystem in the Box is freezing. The Host System is ok.

[liveuser@eos-2022.06.23 ~]$ inxi -Fxxxz
System:
Kernel: 5.18.5-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
Desktop: Xfce v: 4.16.0 tk: Gtk v: 3.24.29 info: xfce4-panel wm: xfwm
v: 4.16.1 vt: 1 dm: LightDM v: 1.30.0 Distro: EndeavourOS
base: Arch Linux
Machine:
Type: Virtualbox System: innotek GmbH product: VirtualBox v: 1.2
serial: Chassis: Oracle Corporation type: 1
serial:
Mobo: Oracle model: VirtualBox v: 1.2 serial:
BIOS: innotek GmbH v: VirtualBox date: 12/01/2006
CPU:
Info: dual core model: AMD Ryzen 5 1600 bits: 64 type: MCP
smt: arch: Zen rev: 1 cache: L1: 192 KiB L2: 1024 KiB
L3: 16 MiB
Speed (MHz): avg: 3200 min/max: N/A cores: 1: 3200 2: 3200
bogomips: 12805
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Graphics:
Device-1: VMware SVGA II Adapter driver: vmwgfx v: 2.20.0.0 ports:
active: Virtual-1 empty: Virtual-2, Virtual-3, Virtual-4, Virtual-5,
Virtual-6, Virtual-7, Virtual-8
bus-ID: 00:02.0 chip-ID: 15ad:0405 class-ID: 0300
Display: server: X.Org v: 21.1.3 compositor: xfwm v: 4.16.1 driver: X:
loaded: vmware unloaded: modesetting alternate: fbdev,vesa gpu: vmwgfx
display-ID: :0.0 screens: 1
Screen-1: 0 s-res: 1920x1200 s-dpi: 96 s-size: 508x318mm (20.00x12.52")
s-diag: 599mm (23.6")
Monitor-1: Virtual-1 mapped: Virtual1 res: 1920x1200 hz: 60 size: N/A
modes: max: 1920x1200 min: 640x480
OpenGL: renderer: llvmpipe (LLVM 13.0.1 256 bits) v: 4.5 Mesa 22.1.2
direct render: Yes
Audio:
Device-1: Intel 82801AA AC97 Audio vendor: Dell driver: snd_intel8x0
v: kernel bus-ID: 00:05.0 chip-ID: 8086:2415 class-ID: 0401
Sound Server-1: ALSA v: k5.18.5-arch1-1 running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.52 running: yes
Network:
Device-1: Intel 82540EM Gigabit Ethernet driver: e1000 v: kernel port: d020
bus-ID: 00:03.0 chip-ID: 8086:100e class-ID: 0200
IF: enp0s3 state: up speed: 1000 Mbps duplex: full mac:
Device-2: Intel 82371AB/EB/MB PIIX4 ACPI type: network bridge
driver: piix4_smbus v: N/A port: N/A bus-ID: 00:07.0 chip-ID: 8086:7113
class-ID: 0680
Drives:
Local Storage: total: 16 GiB used: 0 KiB (0.0%)
ID-1: /dev/sda vendor: VirtualBox model: VBOX HARDDISK size: 16 GiB
speed: 3.0 Gb/s type: N/A serial: rev: 1.0 scheme: MBR
Partition:
ID-1: / size: 10 GiB used: 1.8 MiB (0.0%) fs: overlay source: ERR-102
Swap:
Alert: No swap data was found.
Sensors:
Message: No sensor data found. Is lm-sensors configured?
Info:
Processes: 151 Uptime: 5m wakeups: 21 Memory: 1.93 GiB
used: 837 MiB (42.3%) Init: systemd v: 251 default: multi-user Compilers:
gcc: 12.1.0 Packages: pacman: 898 Shell: Bash v: 5.1.16
running-in: xfce4-terminal inxi: 3.3.18

I would wonder if you may be running out of memory.

Less than 2GiB is probably enough to run EOS but it might be too little for the installer and the installation process.

Yes, because on the live ISO, the filesystem overlay is hosted in RAM. That pulls the all the update files into RAM and then also installs the packages into RAM and you don’t have enough available for that.

haha. i was just gonna write that i found that out too. i thought for a small install like that 2gb would be enough. works now. thanks for getting back! : )

1 Like

2.5GB is minimum in virtual box for the VM for install process if you do online install… offline work with 2GB.

Calamares uses RAM temp mounts…

And online installs will download into this…

So it could be LXQT or LXDE would work but Plasma/kde could fail :wink: