Archmain utility

Greetings. I am trying to use Archmain, I made the installation and it seems to work, it appears on the desktop but opens and clicked immediately, I tried to see in the terminal if they are missing packages and this is the result, I tried to install Pikaur but I don’t Install because in the end this other Python Setuptools package is missing that I can’t install.


yay -Syu pikaur

I was going to type that :stuck_out_tongue:

Uploading: ultima.png…
questo è quello che ottengo alla fine

Uploading: aiuto 2.png…

That almost always means you used sudo pip to install some python tool or library. This will break pacman’s ability to install or update python packages. Use sudo pip to uninstall anything you installed that way then try again.

this is what it gives me i try to install that package but it doesn’t work

Yes, until you remove the copy of setuptools you installed manually, you will continue to get that error.

How do I remove that package? Then I have to reinstall with the previous procedure?

That depends how you installed it. Whatever manual method you used, you need to reverse.

For example, if you used sudo pip, use that same command but tell it to remove it instead of installing it.

can you post me commands to remove the packages, i’m not sure how i installed the old packages

If you don’t how you installed them, I can’t tell you how to remove them.

If you have been manually installing things and not keeping track it is probably better to reinstall so you can start clean.

do you want to reinstall the software? or python

If you have done things to your system manually that you haven’t kept track of you should consider reinstalling EndevourOS itself.

As long as you use pacman to install things, everything will be kept clean. As soon as you start manually installing software to system locations, you end up with a mess.

1 Like

Problem solved, I reinstalled the system and installed all the missing packages, this time I had no problems. Thanks to the availability.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.