[Archlinux]pacman 6.0 and pamac-aur compatibility

Yes, this worked out.

$ sudo rm -f /var/lib/pacman/sync/*
$ sudo pacman -Syu
:: Pakket-databases synchroniseren...
 core                            133,3 KiB   385 KiB/s 00:00 [--------------------------------] 100%
 extra                          1549,8 KiB  1045 KiB/s 00:01 [--------------------------------] 100%
 community                         5,6 MiB  1201 KiB/s 00:05 [--------------------------------] 100%
 multilib                        150,4 KiB   976 KiB/s 00:00 [--------------------------------] 100%
 endeavouros                      17,3 KiB  56,5 KiB/s 00:00 [--------------------------------] 100%
:: Volledige systeemsupgrade starten...
 er valt niets te doen

1 Like

Everything works fine for me except Pamac-all so I guess will have to wait for it to get upgraded…

Good to know that your pacman is working now.
Perhaps you could check with @manuel later on regarding the extra repos when pamac’s issue has been resolved.

Yes, I’ll do that and thanks.

1 Like

After the pacman v6 update I had to re-locate my personal repositories. For some reason pacman v6 feels some file names that worked well in pacman v5 are now too long.

So users of my repos must manually make small changes in files

  • /etc/pacman.d/mirrorlist-m
  • /etc/pacman.conf

Here’s a news update about the required manual intervention:
https://github.com/manuel-192/m-repo-info/blob/master/README.md

3 Likes

Is that everyone who uses endeavour, or was this something you had to have manually setup anyway? Everything on my end seems to be working fine.

That applies only to those that use my personal repositories.
So nothing for users having only official EndeavourOS and Arch repositories.

1 Like

Got it! And thanks for your work yesterday. After such a major event unless someone uses pamac or one of the other GUI’s, anyone who didn’t use their computer yesterday can pretty much update and has no idea anything even happened. That’s impressive.

2 Likes

I think it was a bit unfortunate that Arch devs released pacman v6 so suddenly.
I guess not many of the Arch devs even noticed that it may cause issues with some github repositories.

Another problem is that certain kinds of github repositories do contain files with really long names.

And this combination created problems.

2 Likes

I think this is the biggest residual issue. The rebuilding of yay wasn’t bad (even though I waited until just a few minutes ago on my Arch KDE, I still had to rebuild it, EOS did not). It did seem sudden, and I was super pissed they dropped it at 20:45 my time at the END of a weekend instead of waiting until maybe this coming weekend.

What do you mean by this?
Yay version 10.2.2-4 should be available from Jun 1:

pacman -Si yay

Just for clarity if anyone else is reading this: This doesn’t pertain to Endeavour*

I updated my Arch KDE install (this computer) just about a half hour ago, AND correctly and completely installed yay 10.2.2.-4. . . and it still didn’t work. yay was still broken on my computer for whatever reason - it wouldn’t update aur and would just fail due to the lib package still. I had to pacman -R it and rebuild it from the AUR instructions.

$ pacman -S --needed git base-devel
$ git clone https://aur.archlinux.org/yay.git
$ cd yay
$ makepkg -si

I removed the build package after and now I’m all back up and going.

Last night I updated my EOS-gnome computer normally and everything worked as if nothing had ever happened.

Seems like pacman wasn’t updated to 6 when you updated yay on Arch KDE?
That would explain it.

And how can that happen? It is (usually) because of Arch mirrors! They can have really outdated packages, so when ranking mirrors, it is very important to use only recently updated mirrors.
Actually I checked some mirrors in Germany and saw that some mirrors (more than one actually) have not been updated in more than a month!

To exclude those mirrors from the ranking, you can use reflector option --exclude. Simply give a unique part of a mirror name to --exclude to exclude it. This option can be given several times. E.g.

reflector --exclude xtom.de ... # looks like the xtom.de mirror is 47 days old now...

See more with command reflector --help

Note that for reflector-simple you can write reflector options into file
/etc/reflector-simple.conf.

1 Like

In this case, it probably isn’t because of mirrors. On Arch, yay is an AUR package, not a repo package.

How did you install it? Are you sure it didn’t get pulled out of your yay cache? Did you install yay or yay-bin?

Note that I was talking about updating pacman, not yay.

1 Like

This is true.

yay - and tbh on this last install - I used archfi (don’t tell the Arch community), so I’m not sure honestly. BUT, it’s rebuilt and working fine again. :slight_smile:

Ah, I see you were thinking his yay was updated and his pacman was behind? I don’t think that is the most likely scenario here.

I suspect that when you re-installed yay, it pulled the already built version out of your yay cache instead of rebuilding it.

I followed the rebuild from yay AUR. I did -R it prior but didn’t clear cache, so that could be true. Either way, this is announcements and news gentlemen, and my computer - EOS and Arch are both working normally again. Let’s worry about helping the others.

2 Likes

I don’t know if I missed something because threads about pacman update are quite a few.
Just a hint :
Due to the pacman update Pamac and Octopi are not working (libalpm version). For those who need/want a GUI for package management, I just wanted to inform, that Bauh still does the job.

Who needs a graphical interface for paсman 6 - tkPacman and Bauh works

1 Like