Archfi install anyone?

su
timedatectl set-local-rtc 1

This sets it to local time.

Still the same time. :thinking:

timedatectl status
Local time: Sun 2020-07-05 00:44:54 EDT
Universal time: Sun 2020-07-05 04:44:54 UTC
RTC time: Sun 2020-07-05 00:44:54
Time zone: America/New_York (EDT, -0400)
System clock synchronized: no
NTP service: inactive
RTC in local TZ: yes

Warning: The system is configured to read the RTC time in the local time zone.
This mode cannot be fully supported. It will create various problems
with time zone changes and daylight saving time adjustments. The RTC
time is never updated, it relies on external facilities to maintain it.
If at all possible, use RTC in UTC by calling
‘timedatectl set-local-rtc 0’.

I set mine this way with dual boot Windows. Maybe you just need to turn on NTP
Edit: No i guess not.

Maybe you need it back now that NTP is on?
timedatectl set-local-rtc 0

Yea i did that and i no longer get the warning:

timedatectl status
Local time: Sun 2020-07-05 00:54:29 EDT
Universal time: Sun 2020-07-05 04:54:29 UTC
RTC time: Sun 2020-07-05 04:54:30
Time zone: America/New_York (EDT, -0400)
System clock synchronized: no
NTP service: inactive
RTC in local TZ: no

Is the time right?

Still 4 hours ahead.

Maybe you just need to adjust it and it will be correct after. I’m not sure when it checks the NTP time servers?

timedatectl set-ntp true ?

timedatectl set-ntp true

Edit:

systemctl status systemd-timesyncd.service

After checking timesyncd.service is it running?

Edit:

[ricklinux@eos-xfce ~]$ systemctl status systemd-timesyncd.service
● systemd-timesyncd.service - Network Time Synchronization
     Loaded: loaded (/usr/lib/systemd/system/systemd-timesyncd.service; enabled; vendor preset: ena>
     Active: active (running) since Sat 2020-07-04 21:02:39 EDT; 2min 32s left
       Docs: man:systemd-timesyncd.service(8)
   Main PID: 677 (systemd-timesyn)
     Status: "Initial synchronization to time server 216.55.208.22:123 (2.arch.pool.ntp.org)."
      Tasks: 2 (limit: 38457)
     Memory: 4.1M
     CGroup: /system.slice/systemd-timesyncd.service
             └─677 /usr/lib/systemd/systemd-timesyncd

Jul 04 21:02:39 eos-xfce systemd[1]: Starting Network Time Synchronization...
Jul 04 21:02:39 eos-xfce systemd-timesyncd[677]: The system is configured to read the RTC time in t>
Jul 04 21:02:39 eos-xfce systemd[1]: Started Network Time Synchronization.
Jul 04 21:02:42 eos-xfce systemd-timesyncd[677]: Network configuration changed, trying to establish>
Jul 04 17:03:13 eos-xfce systemd-timesyncd[677]: Initial synchronization to time server 216.55.208.>
[ricklinux@eos-xfce ~]$ 

● systemd-timesyncd.service - Network Time Synchronization
Loaded: loaded (/usr/lib/systemd/system/systemd-timesyncd.service; disabled; vendor preset: enabled)
Active: inactive (dead)
Docs: man:systemd-timesyncd.service(8)

I think you have to enable and start?

systemctl enable systemd-timesyncd.service

systemctl start systemd-timesyncd.service

Ok i did a timedatectl set-ntp true & my timedatectl status reads:

timedatectl status
Local time: Sat 2020-07-04 21:10:53 EDT
Universal time: Sun 2020-07-05 01:10:53 UTC
RTC time: Sun 2020-07-05 01:10:53
Time zone: America/New_York (EDT, -0400)
System clock synchronized: yes
NTP service: active
RTC in local TZ: no

Time & Date are now correct.

Forgot to also mention i did a

dad:~ $ systemctl status systemd-timesyncd.service
● systemd-timesyncd.service - Network Time Synchronization
Loaded: loaded (/usr/lib/systemd/system/systemd-timesyncd.service; enabled; vendor preset: enabled)
Active: active (running) since Sun 2020-07-05 01:10:42 EDT; 3h 56min left
Docs: man:systemd-timesyncd.service(8)
Main PID: 2361 (systemd-timesyn)
Status: “Initial synchronization to time server 71.19.144.140:123 (0.arch.pool.ntp.org).”
Tasks: 2 (limit: 19105)
Memory: 2.1M
CGroup: /system.slice/systemd-timesyncd.service
└─2361 /usr/lib/systemd/systemd-timesyncd

1 Like

You can also check.

timedatectl timesync-status

1 Like

On mine i have to set-local-rtc 1 when dual booting with windows otherwise they are always out 4 hours when i boot back and forth.

1 Like

Thanks Rick!

1 Like