Arch found instead of EOS

I used Endeavour OS on my two laptops, today I decided to go for an installation also on my desktop. After the installation tho, somehow I found arch linux instead of Endeavour. I think because I unselected almost all packages from the installer except the really needed ones. E.G. networkmanager, mtools, dosfstools… can I fix this?

I think you’ll want the eos-hooks package. I think.


Thank you a lot, I think something else might be needed tho, do you have any idea?

Hmm, well, I don’t actually use EndeavourOS, so…

I was under the impression that eos-hooks took care of /etc/lsb-release and /etc/os-release, which should be all you need to identify the OS. Perhaps I am mistaken.


What is it you wanted to have installed?



1 Like

When I log in in tty or also in neofetch the result was Arch linux.

Because now the result is not archlinux but “x86_64” like a generic OS.

What happens if you run /usr/bin/eos-hooks-runner ?

1 Like

Okay so, the problem is I didn’t have lsb-release installed. The file existed but contained only one line “rolling”. I removed the file and installed lsb-release and it worked. Thanks a lot :slight_smile:

1 Like

Solved right now, thanks a lot!

Yes, if you uncheck the Endeavouros section of the install, you don’t install everything that actually makes it EOS.

1 Like
  • name: “Base-devel + Common packages”
    description: “Recommended. Don’t change unless you know what you’re doing (generic).”
  • name: “EndeavourOS Apps”
    description: “EndeavourOS tools and applications”

at least this groups is needed from basedevel common group to have EndeavourOS running


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.