Arch/Cinnamon install question

Should i just ignore this, not sure how it happened lol?

[dad@archlinux ~]$ sudo pacman -Syu
[sudo] password for dad:
:: Synchronizing package databases…
core is up to date
extra is up to date
community is up to date
multilib is up to date
:: Starting full system upgrade…
warning: lib32-vulkan-intel: local (21.1.3-1) is newer than multilib (21.1.2-1)
warning: mesa: local (21.1.3-1) is newer than extra (21.1.2-1)
warning: qt5-base: local (5.15.2+kde+r200-1) is newer than extra (5.15.2+kde+r199-1)
warning: qt5-declarative: local (5.15.2+kde+r29-1) is newer than extra (5.15.2+kde+r28-1)
warning: vulkan-intel: local (21.1.3-1) is newer than extra (21.1.2-1)
there is nothing to do

:thinking: :thinking:

Check your pacman.conf you may have accidentally enabled the multilib and multilib testing repos.

2 Likes

Whenever you get that error the first thing I would recommend is re-sorting your mirrors from the welcome app.

I believe the multilib repo is enabled by default on EOS.

1 Like

It is. I went that direction because they have newer packages then the standard repos. The only way I can think of that happening is if they enabled the testing repos after or in conjunction with the stable ones.

1 Like

Are you installing this desktop along with another install such as kde?

That will make the error go away, but it isn’t always a good idea to solve it that way.

If it is a mirror problem and the mirror is in a bad state you are essentially forcing your system into a matching bad state.

Also, I am not sure why you would use that crazy sequence. You can just use pacman -Syuu instead of those 3-4 commands. However, I don’t generally recommend doing that until you determine why you have newer packages.

The testing repositories are disabled by default. To enable, uncomment the

repo name header and Include lines. You can add preferred servers immediately

after the header, and they will be used before the default mirrors.

#[testing]
#Include = /etc/pacman.d/mirrorlist

[core]
Include = /etc/pacman.d/mirrorlist

[extra]
Include = /etc/pacman.d/mirrorlist

#[community-testing]
#Include = /etc/pacman.d/mirrorlist

[community]
Include = /etc/pacman.d/mirrorlist

If you want to run 32 bit applications on your x86_64 system,

enable the multilib repositories as required here.

#[multilib-testing]
#Include = /etc/pacman.d/mirrorlist

[multilib]
Include = /etc/pacman.d/mirrorlist

An example of a custom package repository. See the pacman manpage for

tips on creating your own repositories.

#[custom]
#SigLevel = Optional TrustAll
#Server = file:///home/custompkgs

Heres the bottom half of my pacman.conf.

Edit: I did a
sudo reflector --latest 30 --country US --age 6 --protocol https --sort rate --save /etc/pacman.d/mirrorlist

then this

[dad@archlinux ~]$ sudo pacman -Syu
:: Synchronizing package databases…
core 133.6 KiB 119 KiB/s 00:01 [--------------------------------------------------] 100%
extra 1566.9 KiB 2043 KiB/s 00:01 [--------------------------------------------------] 100%
community 5.6 MiB 6.36 MiB/s 00:01 [--------------------------------------------------] 100%
multilib 149.6 KiB 224 KiB/s 00:01 [--------------------------------------------------] 100%
:: Starting full system upgrade…
resolving dependencies…
looking for conflicting packages…

Package (10) Old Version New Version Net Change Download Size

extra/firefox 89.0.1-1 89.0.2-1 -0.62 MiB 60.12 MiB
core/groff 1.22.4-5 1.22.4-6 0.03 MiB 2.14 MiB
multilib/lib32-vulkan-icd-loader 1.2.176-1 1.2.182-1 0.00 MiB 0.12 MiB
extra/libcanberra 0.30+2+gc0620e4-4 0.30+2+gc0620e4-5 0.00 MiB 0.09 MiB
core/libldap 2.4.58-3 2.4.59-1 0.00 MiB 0.30 MiB
core/libxcrypt 4.4.22-4 4.4.23-1 0.00 MiB 0.09 MiB
community/nodejs 16.3.0-1 16.4.0-1 0.18 MiB 8.89 MiB
community/signal-desktop 5.6.0-1 5.6.1-1 0.02 MiB 104.10 MiB
extra/vulkan-icd-loader 1.2.178-1 1.2.182-1 0.00 MiB 0.11 MiB
extra/xf86-input-libinput 1.0.1-1 1.1.0-1 0.00 MiB 0.04 MiB

Total Download Size: 175.99 MiB
Total Installed Size: 575.87 MiB
Net Upgrade Size: -0.39 MiB

:: Proceed with installation? [Y/n]

Now all is well, no more warnings. Not sure what happened lol.

It’s what @dalto said then. Your mirrors got out of whack somehow and caught back up.

1 Like

Thanks @dalto , @Elloquin @ricklinux & everyone else. Thats what i usually do is update my mirrors, but i guess when you stay up to late you tend to forget lol.