Anybody got Nvidia 3060Ti laptop working?

I recently installed endeavouros on a new laptop with intel CPU and 3060Ti. The nouveau driver works, but I can not get the hardware acceleration to work. Everytime I tried to switch to nvidia driver, it resulted in failure to boot the system.

I tried the nvidia-installer-dkms and nvidia-inst --series 515.

Anybody using same GPU? Can you share which kernel and driver versions to use? Thanks for helping!

installed Artemis (offline version, then switched to i3 and updated to latest version)
for gpu, i use optimus-manager, no problems here

Welcome to the forum @dasjlkks :enos_flag: :partying_face::balloon::tada:

1 Like

I have a RTX3070 Legion, am at work, from memory it worked with DKMS on all kernels I tried - Linux, zen & AMD all current version (5.18.??).

Did you install the nvidia proprietary driver during the system installation or installed it afterward?

I tried to boot the live system with nvidia driver loaded (I think it’s the second option in the liveusb boot menu) but it failed to start GUI.

My current linux kernel version is 5.18.x. Can you share your nvidia driver version? Thanks!

You’ll need to provide more information that “it doesn’t work”.

For example, start here: [FAQ] Computer doesn’t boot, boots to a black screen, or stops at a message

I will make a guess: Your CPU is either Gen11 or Gen12. If I am right, either use LTS kernel or use kernel parameter ibt=off.

2 Likes

Did you try as @mrvictory suggested to use the kernel parameter ibt=off and update grub.

Thanks, everybody! My CPU is 12th gen. I finally get the Nvidia driver working. These are what I did,

  • enable both intel and Nvidia graphics cards in bios (previously only Nvidia was activated)
  • install optimus-manager (https://discovery.endeavouros.com/nvidia/optimus-manager-for-nvidia/2021/03/), the intel graphics card is working, but switching to Nvidia or hybrid fails to start X
  • install nvidia-dkms (since I am using zen kernel)
  • add two more kernel parameters nvidia-drm.modeset=1 and ibt=off in /boot/grub/grub.cfg. I can switch to nvidia to hybrid mode from optimus-manager after this step

Somehow the auto-detected frequency is not correct for my second monitor, I had to configure it in nvidia-settings.

1 Like

i just installed offline version, upgraded system using pacman -Syu and installed optimus-manager
no other configurations and everything works fine
tested this on a new laptop (asus n552vw, 6700hq + 960m) and works well here too