Another thread: Windows not showing in Grub

I have a Lenovo Legion-type laptop that runs on two SSDs, one main one and an expandable secondary one. I have Windows on my second SSD and recently installed an encrypted EOS on the first, however after installing it Windows is not showing up in Grub or in my system boot order. After looking for solutions and seeing several other posts addressing this same issue, I have done the following:

  • Tried to configure /boot/grub/grub.cfg by adding GRUB_DISABLE_OS_PROBER=false at the end of the config (even though this line was already present in my config).
  • Installed Grub Customizer to detect Windows partition, did not detect it.
  • Switched the BIOs settings around, including but not limited to, re-arranging the boot order, switching to Legacy Boot, etc.
  • Read the Arch Wiki on detecting other Operating Systems:, but wasn’t readable.

Despite having the exact same problems as the users who have had this problem before me, I cannot apply the same solutions. So, since my installation is new, these are the other things I can try:

  • Replace EOS with another Linux distribution, such as Fedora or an Ubuntu-based derivative.
  • Replace EOS with Windows 10 LTSC, taking advantage of the Windows Boot Option Menu to restore visibility of my main Windows partition.
  • Replace Grub? I don’t how to do this.
  • Make Windows Boot Manager run first. Due to issues of not seeing W10 on my system boot menu I thus far can’t do this.
  • Use a disk management application?

Any ideas?

Do you have the package ntfs-3g installed? If not install it and update grub.

Yes I have this installed it. My grub is up-to-date. Windows is still not visible on grub.

That was all I could think off. I assume you have os-prober installed so I don’t think I can help you out

And make sure both are installed using GPT.

Did you update grub after changing the config file?

sudo grub-mkconfig -o /boot/grub/grub.cfg
1 Like

If you’d like, you can add this to /etc/grub.d/40_custom to get a Windows boot entry. The entry after --set=root is the UUID of /boot/efi:

menuentry 'Windows' {
    search --fs-uuid --no-floppy --set=root 148D-D264
    chainloader (${root})/EFI/Microsoft/Boot/bootmgfw.efi

Another alternative is to install rEFInd to handle the booting instead of grub. I have never seen rEFInd miss an install of Windows if present.

An easy to follow Wiki entry can be found on this site (it must be easy, I wrote it :grin:) - but testing it is just an install and one command - refind-install which should get you going…

1 Like

If you wrote it must be easy to follow :stuck_out_tongue: for us.

It could be one of those cases where it fails to read the efi partition in Windows for some reason sometimes unknown.

It is also possible that the efi partition is too small (if it was picked up at all) and so on… but trying rEFInd will tell us if something is wrong! If there is a viable Windows out there, it’ll find it…

I know …using it too! :wink: Just pointing the fact out that that i have had a couple users with this issue and it is not anything to do with EndeavourOS.

Yeah - we just narrow it down with different methodologies!

The output of sudo fdisk -l would help too, probably :grin:

Make sure you have os-prober installed too.

the interesting question would be how partitions are looking…
And having two disks dedicating one for windows and the other for Linux should be the best way to have not much issues at all. But you need to make sure to create a new ESP for the Linux install and NOT using the one from Windows on the other partition, this will make you able to boot into windows from the UEFI firmware menu (F12 in most cases)

lsblk -f to see how partitions are done…
In addition it could be that windows was using the second harddrive within a raid or as recovery backup solution what could be the issue also.

What do you mean here, “wasn’t readable” ?

1 Like

Maybe it means not understanding? Or it didn’t pick up the other OS they mean?