AMDGPU support for Radeon HD 6370D

I’m working on an older computer that is going to be a kids game PC at a day care facility. It is an old HP Pavilion that has what LSPCI -k states to be an "AMD/ATI SuperSumo [Radeon HD 6370D] video card.

With default install settings, the login screen is just a white screen with color patterns. I can switch to a terminal and looking at DMESG, I’m getting an error message of:

radeon: failed testing IB on GFX ring (-110)

Looking at lspi -k it states “Kernel modules: radeon”. Having followed these instructions and also these instructions which are basically the same just more condensed I believe lspci -k should return “Kernel modules: radeon amdgpu” but it doesn’t appear as if the amdgpu driver wants to load for this graphics card.

The unless there are some kernel switches I can pass to the radeon driver, I don’t see how I am going to get it to to work but with the amdgpu driver not loading at all, I seem to be at a standstill.

Any suggestions?

Do you have xf86-video-ati installed?


1 Like

yes @Pudge is right: it is Northern Islands GPU:
Supported by xf86-video-ati not the amdgpu driver.
see here:


Sorry, should have been clearer… Default install loads the xf86-video-ati driver and that is what gives the white corrupted screen and the kernel error messages. In my trouble shooting I was trying to use the AMDGPU driver but it looks like I missed the table that it would only work for Southern Island cards.

So, in that regards, I will reset back to trying to diagnose the xf86-video-ati driver and why it is locking the system.

Here is a picture of what I get when the Display Manager loads. Below that is a picture of what journalctl -k returns if I switch to another console with CTL+ALT+F3 and login to the terminal.


could be a kernel issue i do not see such output for a very long time …

you could try lts kernel:
sudo pacman -S linux-lts linux-lts-headers

Tried the LTS kernel but the same problems.

and LiveISO-installer working without issue?
The output indicates something genral is failing with the driver but… it could be also loginmanager :
lightdm have an issue where it happens that it starts faster than X is ready, or the GPU driver is not fully loaded, one solution is to set logind-check-graphical=true inside lightdm.conf

uncomment the line #set logind-check-graphical=false and change from false to true like so:

set logind-check-graphical=true

Or early load/kms is not working:

It is late here so we could check more tomorrow :wink:

It should work on the amdgpu. I have a 6450 running on it. Do you have xf86-video-amdgpu installed and see if uninstalling xf86-video-ati works.

Yes, I tried the amdgpu driver and uninstalled the ati driver but it only starts with I think the vesa frame buffer driver if I do that (can’t change the resolution and it is stuck at 800x600).

In my earlier posts I was trying to force the amdgpu driver to work but jokamprad mentioned it doesn’t support the Northern Island chips (though not sure if he was meaning by default or at all since there is the workaround to enable amdgpu for some older chips).

I will try joekamprad’s suggestion with lightdm tonight to see if that does anything.

I will boot that machine and check because it is a 6450 card although it’s recognized as a 7450 which is possible that they put the newer chip on it. When i purchased it the box show’s it’s a 6450 card.

Edit: Yes, it is using the xf86-video-ati and it’s listed as a 7450 card

Edit2: Because my card is a 7000 series it uses amdgpu*/ati from my understanding.

Is xf86-video-intel installed, if so try removing it.


Both the xf86-video-ati and the xf86-video-amdgpu are installed. It loads the xf86-video-ati but i think it also needs amdgpu to work. It has an xorg file for each in /usr/share/x11/xorg.conf.d

Radeon HD 6450 (Caicos) here no way to run it on amdgpu drivers

I thought it was running on amdgpu but it say’s ati loaded. But it is recognized as a 7450 so they may have boxed the wrong card at the manufacturer. It’s my understanding that the 7000 series cards use ati but the amdgpu has some part int it? I don’t know? They list it as ati*/amdgpu on the chart. I know my RX 590 series definitely is all amdgpu.

Back at work and back to trying to get this computer running so I can get it out to the kids. So it looks like the proper driver is the xf86-video-ati driver by the consensus of the posts. Are there some kernel options for the driver that I can try to see if I can find a config that works? Also, is there any way other than changing the grub boot menu the only way to pass kernel options to the module at boot?

Did you get the screen problem resolved?

No, that is what I meant. I am back to trouble shooting the issue. Need to figure out of their are any options I can pass to the xf86-video-ati module to see if it will stop the screen corruption.

Im no expert but did you try another distro with an even older kernel? Like 4.14 or 4.19? When i was using debian 10 with 4.19 kernel it loaded ati driver and everything worked just fine. I then had to enable non free repository and download linux-amd-firmware(something like that) and then it loaded radeon which is my default driver. Its an southern islands card.

the only thing i can think of is to add radeon module inside /etc/mkinitcpio.conf and rebuild kernel images:

# The following modules are loaded before any boot hooks are
# run.  Advanced users may wish to specify all system modules
# in this array.  For instance:
#     MODULES=(piix ide_disk reiserfs)

sudo mkinitcpio -P

what will force enable early load of the module