ALSA: playback issues

Everytime I’m trying to use a text-to-speech program, I get the same error message:

“festival> (SayText “testing”)
ALSA lib pcm_dmix.c:1032:(snd_pcm_dmix_open) unable to open slave
-=-=-=-=-=- EST Warning -=-=-=-=-=-
audio_open_alsa: failed to open audio device default. No such file or directory”

running “cat /proc/asound/cards” lists two options:

HDA ATI HDMI at 0xfcf60000 irq 54
1 [Generic ]: HDA-Intel - HD-Audio Generic
HD-Audio Generic at 0xfcc00000 irq 56

The audio works fine by the way, it’s just that I can’t use text-to-speech because of this issue.

I don’t have knowledge about audio related matters so if someone could help me out with this I would greatly appreciate it.

This might be related to your /etc/asound.conf, or ~/.asoundrc if you created that file.

Depending on which audio device should be the default, edit these lines with either a 1 or 0.


defaults.pcm.device 0 
defaults.ctl.card 0 
defaults.pcm.card 0
defaults.timer.card 0

There are no such files in the /etc/ directory. Should I create asound.conf myself??

Ok, probably better to make a local file, ~/.asoundrc

all right, I created .asoundrc in the home folder but unfortunately the problem persists with the same error message.

placing it in /etc/ isn’t possible due to permissions. but that’s probably not what I should be doing anyway.

You’ll need to logout for the changes to take effect, by the way.

Nope, still not working :confused:

Are you running on pulseaudio or pipewire?
If pulseaudio, try installing the pulseaudio-alsa package.

both packages are already installed.

I’m not sure what else to suggest, maybe @ricklinux can think of something?