All videos stuck when using laptop speaker but works connected to bluetooth headphones

System Info : https://clbin.com/OMN77

I seem to not be able to play any videos (on browser or on system) when NOT connected to any headphones. The video just freezes in place. I think this could be due to some audio settings issue since I used pulse audio to setup my WHXM1004 headphones.
But videos do not work properly on my laptop speakers.

Could it be due to missing codecs?
https://wiki.archlinux.org/title/GStreamer#Installation
https://wiki.archlinux.org/title/Codecs_and_containers#Video_codecs
I’m quite sure, there are multiple issues involved, but the video-freezing goes first. Right?

First off, welcome to the EndeavourOS forum. I hope you enjoy your time here.

You are correct, incorrect audio settings will cause the video to freeze.

Start a video, then launch “PulseAudio Volume Control” from the apps menu, or enter “pavucontrol &” in a terminal window.

Go to the “Output Devices” tab. This looks like this on my computer. Yours will look different.
OutputDevices
One of the devices should have the volume meter meter moving back and forth. In my case
“Port HDMI / DisplayPort 4 (plugged in)”

If none of the “Ports” have the volume meter moving, then click on the “Configuration” tab, then click on one of the “Profile” entry boxes.

Configuration
Most of drivers are unavailable, but “Digital Stereo ( HDMI 4 ) Output” works my Desk Top.
You might want to look for something relating to the lap top speakers.
Now go back to the “Output Devices” tab and see if one of the Ports has a moving volume meter.

Now go to the “Playback” tab.
Playback
The volume meter should be moving, if not, Click on the Port: entry box to get the drop down box. Choose different choices until you get audio.

Now jump between the three tabs until the right combination is found.

Note: There might be a slight delay when changing options for the audio to start.

Good Luck.

Pudge

EDIT:
If you want to switch back and forth between the headphones and the laptop speakers, you will need to do this with the “Playback” tab in pavucontrol. Most likely there will not be an auto switch between the two.