Airootfs error when booting iso in Multiboot usb

I have added Endeavour OS to my Linux demo usb pendrive (/dev/sdc) but I haven´t been able to boot it due to the following error:

The error occurs with both versions shown in the layout below:

sdc       8:32   1  58,2G  0 disk 
├─sdc1    8:33   1  47,3G  0 part /run/media/arthur/MultiusbMBR
├─sdc2    8:34   1     5G  0 part /mnt
└─sdc3    8:35   1   5,8G  0 part 

[arthur@arthur-lifebooke743 ~]$ ls /mnt
**endeavouros-2021.08.27-x86_64.iso**  lost+found

[arthur@arthur-lifebooke743 ~]$ ls /run/media/arthur/MultiusbMBR
boot  dev_save  Docs  ISOs  lost+found

[arthur@arthur-lifebooke743 ~]$ ls /run/media/arthur/MultiusbMBR/ISOs
#  and many other OSes

The same error occurs in very similar form with SysrecueCD versions 7.00 & 8.01.

Manjaro, Arcolinux and Artix are booting.
Another USB with endeavouros-2021.04.17-x86_64.iso placed by dd comand boots fine.

My grub menuentry for one the 2 versions (the entries are pratically identical) :

menuentry "9 - Endeavour OS 2021.08.27" {
     set root=(hd0,msdos2)
     set isofile="/endeavouros-2021.08.27-x86_64.iso"
     loopback loop (hd0,msdos2)$isofile
     linux (loop)/arch/boot/x86_64/vmlinuz-linux archisobasedir=arch cow_spacesize=10G archisolabel=MultiusbMBR i915.modeset=1 radeon.modeset=1 nvidia.blacklist=yes modprobe.blacklist=nvidia nouveau.modeset=1 nouveau
     initrd (loop)/arch/boot/intel-ucode.img (loop)/arch/boot/amd-ucode.img  (loop)/arch/boot/x86_64/initramfs-linux.img

The few threads I found with the same error message never got any decisive answer.

I have been using Endeavour for a few weeks and I like it so I want to be able to take it with me - without carrying yet another usb pendrive.

Maybe this doesn’t help much, but as you have hard-coded disk and partition in the grub menuentry, they can be made not so hard-coded. It is based on assigning $root by searching the ISO file.

Something like this:

menuentry 'EndeavourOS 2021.08.27' {
    set isofile=/endeavouros-2021.08.27-x86_64.iso
    search --no-floppy --set=root --file $isofile
    probe -u $root --set=uuid
    loopback loop $isofile

    # Add your linux and initrd lines.

    # For reference here's the parameters I have been using:
    # linux (loop)/arch/boot/x86_64/vmlinuz-linux img_dev=/dev/disk/by-uuid/$uuid img_loop=$isofile
    # initrd  (loop)/arch/boot/intel-ucode.img (loop)/arch/boot/x86_64/initramfs-linux.img
1 Like

Thanks Manuel, sounds good! I will try it tonight

It worked ! So simple.
Many thanks, I had lost much time with that !

1 Like