After update ip screwed up. No exce0t by hotspot

I updated my computer two days ago. And after restarting it, I lost my ability to go online.

Looing at KDE Connect, my router is now listed as lo with the IP address as 127.0.0.1. Netmask 255.0.0.0 Gateway is 0.0.0.0.

This I am looking at from [fuzzy@ted-gazelle ~]$ ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host noprefixroute
valid_lft forever preferred_lft forever
2: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
link/ether e8:84:a5:7e:c3:13 brd ff:ff:ff:ff:ff:ff
inet 192.168.0.139/24 brd 192.168.0.255 scope global dynamic noprefixroute wlan0
valid_lft 6525sec preferred_lft 6525sec
inet6 fe80::fadb:682c:1df:fcc0/64 scope link noprefixroute
valid_lft forever preferred_lft forever

When using the terminal, This is what I got with ip addr

[fuzzy@ted-gazelle ~]$ ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host noprefixroute 
       valid_lft forever preferred_lft forever
2: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether e8:84:a5:7e:c3:13 brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.139/24 brd 192.168.0.255 scope global dynamic noprefixroute wlan0
       valid_lft 6525sec preferred_lft 6525sec
    inet6 fe80::fadb:682c:1df:fcc0/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

Looks like it’s correct to me from the terminal. Not sure what Kde connect has to do with it.

Edit:

Have you rebooted since the update?

Edit: Can you ping google

ping -c 3 google.com

It has already been rebooted several times.

By the way, I didn’t mean to say that KDE was the cause. I was just referring to how it was displayed.

Now I went to run an errand and just came back. So now my Wi-Fi is working OK; Which makes me pretty happy. But I still can’t get it to run through the router by Ethernet cable.

Edit. The Ethernet does say connected. It just doesn’t run through it.

lo is your local loopback. wlan0 is your WiFi connection. The ip addr is not detecting an Ethernet connection. Here is a snippet of my ip addr displaying the Ethernet connection.

2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether a8:a1:59:e1:2e:33 brd ff:ff:ff:ff:ff:ff
    altname enp3s0
    inet 192.168.0.108/24 brd 192.168.0.255 scope global dynamic noprefixroute eno1
       valid_lft 6482sec preferred_lft 6482sec
    inet6 fe80::4744:bdbc:7ab5:3593/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

In the 4th line down, the “inet 192.168.0.108/24” is the current DHCP address of and at the end of the line is “eno1” which is the device name for Ethernet.

try this command, here is my results

ip route
default via 192.168.0.1 dev eno1 proto dhcp src 192.168.0.108 metric 100 
192.168.0.0/24 dev eno1 proto kernel scope link src 192.168.0.108 metric 100

default via 192.168.0.1 is the IP addr of the router. dev eno1 is the device name, eno1 in my case. prot dhcp is the protocol. and src 192.168.0.108 is the current dhcp address of my computer.

 systemctl status NetworkManager
● NetworkManager.service - Network Manager
     Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; preset: disabled)
     Active: active (running) since Sat 2023-08-05 09:59:58 MDT; 7h ago
       Docs: man:NetworkManager(8)
   Main PID: 450 (NetworkManager)
      Tasks: 5 (limit: 18740)
     Memory: 15.4M
        CPU: 1.571s
     CGroup: /system.slice/NetworkManager.service
             └─450 /usr/bin/NetworkManager --no-daemon

Aug 05 10:00:05 J5040 NetworkManager[450]: <info>  [1691251205.7750] manager: startup complete
Aug 05 10:00:06 J5040 NetworkManager[450]: <info>  [1691251206.1454] manager: NetworkManager state is now CONNECTED_GLOBAL
Aug 05 10:00:08 J5040 NetworkManager[450]: <info>  [1691251208.8785] agent-manager: agent[ad1369cb22d44e7e,:1.32/org.kde.plasma.net>
Aug 05 11:00:05 J5040 NetworkManager[450]: <info>  [1691254805.0978] dhcp4 (eno1): state changed new lease, address=192.168.0.108

it should look similar to the above. Should be loaded and active. If not

sudo systemctl enable --now NetworkManager.service

Next, on KDE panel, click on the Network icon at the right.
should say “wired connection 1” then click on “wired connection 1” then click on Details.

stranger4395-2

If you are not getting as above then let us know.

Pudge

Thanks Pudge.

I followed each of the commands.

Unfortunately, I couldn’t get Networks to display a Wired connection

[fuzzy@ted-gazelle ~]$ ip route
default via 192.168.0.1 dev wlan0 proto dhcp src 192.168.0.139 metric 600 
192.168.0.0/24 dev wlan0 proto kernel scope link src 192.168.0.139 metric 600 
[fuzzy@ted-gazelle ~]$ 

[fuzzy@ted-gazelle ~]$  systemctl status NetworkManager
● NetworkManager.service - Network Manager
     Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; preset: disabled)
     Active: active (running) since Sat 2023-08-05 20:17:44 PDT; 1h 1min ago
       Docs: man:NetworkManager(8)
   Main PID: 846 (NetworkManager)
      Tasks: 4 (limit: 76769)
     Memory: 15.5M
        CPU: 4.723s
     CGroup: /system.slice/NetworkManager.service
             └─846 /usr/bin/NetworkManager --no-daemon

Aug 05 20:18:37 ted-gazelle NetworkManager[846]: <info>  [1691291917.6710] device (wlan0): state change: secondaries -> activated (reason 'none', sys-iface-state: 'managed')
Aug 05 20:18:37 ted-gazelle NetworkManager[846]: <info>  [1691291917.6712] manager: NetworkManager state is now CONNECTED_SITE
Aug 05 20:18:37 ted-gazelle NetworkManager[846]: <info>  [1691291917.6720] device (wlan0): Activation: successful, device activated.
Aug 05 20:18:37 ted-gazelle NetworkManager[846]: <info>  [1691291917.6729] manager: startup complete
Aug 05 20:18:38 ted-gazelle NetworkManager[846]: <info>  [1691291918.0231] manager: NetworkManager state is now CONNECTED_GLOBAL
Aug 05 20:20:15 ted-gazelle NetworkManager[846]: <info>  [1691292015.8427] audit: op="statistics" interface="wlan0" ifindex=2 args="2000" pid=1171 uid=1000 result="success"
Aug 05 21:05:14 ted-gazelle NetworkManager[846]: <info>  [1691294714.0777] audit: op="statistics" interface="wlan0" ifindex=2 args="2000" pid=1171 uid=1000 result="success"
Aug 05 21:07:09 ted-gazelle NetworkManager[846]: <info>  [1691294829.7087] audit: op="statistics" interface="wlan0" ifindex=2 args="2000" pid=1171 uid=1000 result="success"
Aug 05 21:10:15 ted-gazelle systemd[1]: Started Network Manager.
Aug 05 21:18:37 ted-gazelle NetworkManager[846]: <info>  [1691295517.6612] dhcp4 (wlan0): state changed new lease, address=192.168.0.139
[fuzzy@ted-gazelle ~]$ 

What does your network show

inxi -Na

Edit: Also have you shutdown your router for a few minutes and restarted it?

What ricklinux said. The inxi -Na command should show exactly what hardware device you have and which driver it needs. Also rebooting your router should be a good thing to do.

In addition, your ip route says it’s “via 192.168.0.1”. Disconnect your WiFi to eliminate it. Then try to ping this IP address from a terminal.

ping 192.168.0.1
PING 192.168.0.1 (192.168.0.1) 56(84) bytes of data.
64 bytes from 192.168.0.1: icmp_seq=1 ttl=64 time=0.592 ms
64 bytes from 192.168.0.1: icmp_seq=2 ttl=64 time=0.526 ms

If none of the above helps, try a different Cat 6 ethernet cable. It only takes one wire to be broken to make it fail. Check the ethernet connector on both the router and computer for possible damage.

Pudge

1 Like
[fuzzy@ted-gazelle ~]$ inxi -Na
Network:
  Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:06f0 class-ID: 0280
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: CLEVO/KAPOK driver: N/A modules: r8169 pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: 3000 bus-ID: 08:00.1 chip-ID: 10ec:8168 class-ID: 0200
[fuzzy@ted-gazelle ~]$ 


[fuzzy@ted-gazelle ~]$ ping 192.168.0.1
PING 192.168.0.1 (192.168.0.1) 56(84) bytes of data.

Note the last part as of now, hasn’t gone any further. When Dry closing the tab, the terminal, a dialog box says that it is still being processed. Even though it has been several minutes

Edit: this is after shutting down and restarting the router.

Further, edit. Wi-Fi went back on. but no successful Ethernet.

The driver isn’t loaded. It wouldn’t hurt to try installing the r8168 package and see if it works on that instead of the r8169 kernel module.

Edit: After installing the package you need to reboot and check again.

inxi -Na

removed and resinstalled r8169

[fuzzy@ted-gazelle ~]$ inxi -Na
Network:
  Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:06f0 class-ID: 0280
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: CLEVO/KAPOK driver: N/A modules: r8169 pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: 3000 bus-ID: 08:00.1 chip-ID: 10ec:8168 class-ID: 0200
[fuzzy@ted-gazelle ~]$ 

No change

Note I rebooted after the last two commands

Did you install the package r8168? You don’t reinstall r8169. It is a kernel module. The r8168 is a package that you install with yay.

Edit: Or is it already installed and you have a conflict? Check:

pacman -Qi r8168

[fuzzy@ted-gazelle ~]$ pacman -Qi r8168
Name            : r8168
Version         : 8.051.02-60
Description     : A kernel module for Realtek 8168 network cards
Architecture    : x86_64
URL             : http://www.realtek.com.tw
Licenses        : GPL
Groups          : None
Provides        : None
Depends On      : glibc  linux
Optional Deps   : None
Required By     : None
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 81.79 KiB
Packager        : Jan Alexander Steffens (heftig) <heftig@archlinux.org>
Build Date      : Thu 03 Aug 2023 09:40:41 AM PDT
Install Date    : Sun 06 Aug 2023 12:51:56 PM PDT
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature

[fuzzy@ted-gazelle ~]$ 

I did use pacman, but if you think that yay will give me better results. I will do that.

So it is installed now? Or it was installed before? Have you rebooted after installing the package and check again:

inxi -Na

I forgot to answer that. It was there before.

[fuzzy@ted-gazelle ~]$ inxi -Na
Network:
  Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:06f0 class-ID: 0280
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: CLEVO/KAPOK driver: N/A modules: r8169 pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: 3000 bus-ID: 08:00.1 chip-ID: 10ec:8168 class-ID: 0200
[fuzzy@ted-gazelle ~]$ 


Is this the output now after it was installed? Or the r8168 was there prior to you trying to install it because the command i gave was just to check if it was installed?

Edit: I’m trying to discern if the r8168 package was already installed because it’s only showing the r8169 kernel module yet it’s not loaded.

Edit2: if it was already installed prior and this is the output then i would uninstall it and reboot.

sudo pacman -R r8168

@stranger4395
No luck? :thinking:

Like magic

Thanks everbody for your help

If you feel this issue is resolved, kindly go to the post that you feel helped you the most in solving the issue. Then click on the
solved
icon

This will trigger the forum software to do it’s Topic solved routine.

Pudge

1 Like

Done. though I wish that I could do this both for you and ricklinux

1 Like