After update, booting up results in a funny screen

I have been using Endeavouros for a while with no issues. However, after switching off two days ago, when I tried today to switch on the computer, the attached image is the result of the image that I get, regardless whether I select “Endeavouros” or “Endeavouros Fallback” from the UEFI entries.

I had not made any changes lately other than updating the system.

If I have a look at the logs, it appears that in the last update the pacman upgrade did not reach the end. I am not sure, but I get as last entry from pacman.log the following line:
[ALPM] running ‘update-desktop-database.hook’…

I have made a chroot to the system from a Live CD and have run pacman but the system is completely up to date.

I think I am using the lightdm display manager (derived from /etc/systemd/system/display-manager.service). I have also some strange messages therein. This is my lightdm.log, this is my seat0-greeter.log, and my X-0.log.

Some other logs: Xorg.0.log and the lastlog is empty.

I have no clue what could be the problem, but before reinstalling from scratch, I have have though I might first ask here for advice.

Thanks in advance!

P.S. Newbie here. not for time of use, since I have been using it after switching from Antergos, to which I switched after Crunchbang was discontinued, but most certainly regarding knowledge of Linux. I just use Endeavouros as an operative system to work on it, and no more than that. For small problems I usually find a “recipe” in the Internet, but for this problem I have no clue even how to search in the Internet for a solution.

image0

Given

[2021-01-03T17:14:49+0100] [ALPM] upgraded mesa (20.3.1-1 -> 20.3.2-2)

and

$ pacman -Q mesa
mesa 20.3.4-1

this suggests you have an issue with your mirror, and/or you have a partial upgrade.

Therefore, chroot again, update your mirrorlist, and make sure you’re actually up-to-date. Then, install another kernel to make sure it’s not just a regression.

My laptop wont boot with kernel 5.10 and another laptop runnng Manjaro offers the same screen like you have with kernel 5.10
Kernel 5.4 is running okay on both machines, both intel cpu and gpu.

Try removing xf86-video-intel and see of that corrects the situation. It did for me but added a few wrinkles. (I had a similar problem.)

Also try booting from the linux-lts kernel instead of the latest kernel. This is what I am doing right now. If you do not also have the lts kernel installed, install it (yay -S linux-lts) and boot the system from it.

I hope that one (or both) of these suggestions helps you.

Lawrence

P.S. I think that this has something to do with the UEFI/BIOS but I don’t know what it could be.

Thanks, Jonathon! Indeed, I had forgotten to update the mirrorlist before updating the system, which from a Live-CD is probably a must.

Regretfully, it did not solve the problem. But I will definitely remember in the future to think about updating the mirrorlist first if I need to update the system via chroot again!

2 Likes

What about

?

Thanks! It solved the problem! I just reverted to the previous version of the Kernel (5.10.11 instead of 5.10.13) and this was enough for the system to boot normally again!

I’ve just received an update to the kernel. now running 5.10.13-2 may help??

1 Like

Sorry, I don’t know whether you mean the same as Lemon, but I have the impression that you mean something else, since you refer to "make sure that it’s not just a regression). As I said in my reply to Lemon, It worked to go back to a previous version of the Linux kernel.

I don’t know what are other kernel possibilities (maybe what lhb1142 proposed with the Linux-lts?). I am sorry, I am quite ignorant about Linux. I just know the very, very basics.

Thanks or the info! I will try!

No luck with 5.10.13-2.

1 Like

A “regression” (i.e. a “backwards step”) happens when something that was previously working is broken in an updated package. Given kernel version 5.10.11 works and 5.10.13 does not, this indicates a regression.

Generally, having both linux and linux-lts kernels installed means you can quickly compare the two in case one breaks, thereby potentially ruling out the kernel as having an impact (that is, if linux-lts works but linux does not then that likely indicates the linux kernel is causing the issue).

2 Likes

Thanks for the clarification, jonathon. That was all new to me!

1 Like

Thanks. I am going to install linux-lts as you and Jonathon propose. It was another solution to the problem similar to the one indicated by Lemon.

Thanks so much you all for the help!

1 Like

Install linux-lts, linux-lts-headers and regenerate grub.

Thanks! I use systemd-boot, so, after installing as lhb1142 proposed, I added instead the corresponding conf files in /boot/loader/entries/.

On the other hand, in order to ensure that the “non-lts” kernel stays in the 5.10.11 version, I have put linux as ignored package in the /etc/pacman.conf. I guess I will have to check periodically whether a new version of the kernel solves the issue by installing and testing it.

Thanks again all for the help! If it weren’t for you, I would have re-installed Endeavouros from scratch unnecessarily, since it would have eventually ended up in the same situation with the problematic kernel after all the updates!

.

You don’t have to ignore linux. Simply update it as usual. Then, from time to time, check if the linux kernel works…

Those kernels can co-exist. Only one of them (that you select at boot) is used at a time.

FWIW, today’s upgrade to 5.10.13.arch1-2 left my computer hanging after loading the kernel. No GUI, just stuck. No-GUI boot works. Also linux-lts boots fine.

It is otherwise a pretty generic system with an AMD Ryzen 3550H and no other graphics- nothing “new” in that sense.

I suppose it is a good idea always to keep one more trusty old kernel around.

1 Like

Thanks, Manuel! I will do as you say. I thought that maybe it was preferable to work with the latest (working) kernel, but I guess that the lts kernel is equally good to work with, and it is then easier to check whether the non lts kernel works in the future.

I guess I was just lucky up to now, because I had only had much minor problems with Linux which enable me to repair it. Good that I learn from you all this weekend to have a trusted kernel to be able to boot up from in case of need!

My system has an almost 10 year old i7-3770K with no additional graphics card, so also nothing fancy on my side.

An update on the problem: the regression now also applies to linux-lts. The update from linux-lts-5.4.98-1-x86_64 to linux-lts-5.10.16-1-x86_64 has left me with exactly the same screen as with the “normal” linux kernel.

I have reverted to the previous working versions of linux and linux-lts and put both linux and linux-lts in the ignored packages in /etc/pacman.conf. I just hope that the bug is one day remedied and will try from time to time to update one of the two kernels and see how it works. I guess there is nothing else I can do now.

this will only work as long as no other kernel relevant package get an update…
Do you try already uninstalling ‘xf86-video-intel’ and using the modsetting driver from kernel itself?
This is suggested for newer intel GPU.

Note: Some (Debian & Ubuntu, Fedora, KDE) recommend not installing the xf86-video-intel driver, and instead falling back on the modesetting driver for Gen4 and newer GPUs (GMA 3000 from 2006 and newer). See [1], [2], Xorg#Installation, and modesetting(4). However, the modesetting driver can cause problems such as Chromium Issue 370022 and vsync jitter/video stutter in mpv.

From your logs I see:

** (lightdm-gtk-greeter:2880): WARNING **: 09:47:11.216: [Background] Failed to load background: Failed to open file “/usr/share/endeavouros/endeavouros-wallpaper.png”: No such file or directory

what says you have uninstalled some packages EOS was installing per default (e.g. theming and branding package endeavouros-theming missing) so may some more packages are missing after you uninstall something.

for lightdm make sure accountsservice is installed, may reinstall lightdm to make sure all deps are installed.

And i would be interested aside from love to help users still here from Antergos :wink: to see your system hardware and bootlog:

lspci > log.txt && lsusb >> log.txt && journalctl -b -0 >> log.txt && cat log.txt | curl -F 'f:1=<-' ix.io