After login, screen turns off, then returns to login-screen

I have installed Endeavor OS for the first time. I chose the KDE desktop. After getting the message from Calamares that the install was complete, I rebooted and I was greeted by the login-screen. (By the way, I did install with XCFE for the first time and the problem was the same.)

I entered my password, then the screen turned off and on again, returning me to the login-screen. (When I enter the wrong passport, I get the message “wrong password” and the screen remains on. It only happens when I enter the correct password.) I tried to get to tty by pressing crtl+alt+F1 (F2 and F3); however, this just returned me to the screen with the systemd messages about the boot (I hope I identify them correctly). There is no way to login or to interact with the pc other than rebooting at this point.

I have seen a thread in this forum (although I seem to be unable to find it again) where a user had a similar problem and he solved it by using an adapter for his monitor. According to that other post, nvidia is to blame because the screen is not recognized via microHDMI. I do not have another adapter for the monitor and I am unwilling to buy one on the off chance that it might work.

My system:
Intel 13700k
Nvidia 3080 ti → the monitor is connected via microHDMI

In another post it was suggested to disconnect the monitor while booting and to reconnect it after login. I tried to do this but the monitor did not show anything and remained blank. Since I cannot enter tty I would assume that I may have to fix this via the live-environment. However, I have no idea what to do.

What gen is that processor?

13th Generation, the latest one. I just bought it a few weeks ago.

Does it need the ibt=off to boot? (on my phone)

it boots without ibit=off