After installation, GNU GRUB shows up and cannot boot

So I just installed EndeavourOS and after reboot the GNU GRUB shows up. I can’t boot into the OS in any way - also, I can’t enter BIOS. Only a white underline shows up and is frozen. I’m really scared about my laptop. When I try to boot into an OS, it says “Security Fail” (note that I had Secure Boot disabled before). What do I do?

welcome here :enos:
sad to hear you have such issue…
But we need more information:
You do choose grub anyway to be used?
what is the hardware exactly and what was selected for the install process?

Just to be clear, is it still disabled?

No, it’s enabled now.

I can’t boot into any other OS, nor get that info, so I will just list info I know:

Intel Core i5-9300H
Nvidia GeForce GTX 1050

I don’t remember much what I installed. I think EFI mode. Also I think I chose to install it on partition, can’t remember. Sorry :sob:

This is the issue. You can’t enable it and then boot EOS.

manual device boot menu from Bios is not showing too? F12 in most systems…

It does, except it shows “Ubuntu” and “Linux Boot Manager”. When I run through “Ubuntu”, the GNU shows up. However, when I try using Linux Boot Manager, it says: “Security Boot Fail”, and when I click Enter, it goes back to GNU.

if it shows Linux Boot Manager you take the default from cassini ISO systemd-boot… and ubuntu can be booted if secure boot is on i bet… but EndeavourOS can not boot with secureboot enabled.

But when I try to use “Ubuntu” it takes me to the GNU.

Have you tried disabling secure boot?

you mean GRUB=

yes it will take you to what ever Ubuntu have installed as bootloader… and a slong as you do not add EndeavourOS to Ubuntus Grub it will not show up there…

If you use default setup from EndeavourOS installer it will install systemd-boot as boot loader and create a boot entry into nvram efiboot called Linux Boot Manager

That’s the problem - I can’t. If I try going into Bios, as I said there’s only an underline that is frozen and doesn’t do anything.

Yes, that’s exactly what I used - systemd-boot.

yes but you need to get into your Bios/firmware again to disable secure boot… is the ubuntu Grub offering an entry for firmware load?

I don’t think so

I don’t think so, cause I am not on the laptop right now. However, I don’t remember it having something like that

could be called “system setup” too

There’s not much commands I remember

i mean a boot menu entry in gnu-grub