Add Printer

Hi, first post, and maybe a daft question.
I’m trying to add an HP deskjet 2710e to Endevouros, and have found (amongst others) a link to
but receive multiple errors and nothing is installed or upgraded. As such the printer doesn’t work :frowning:
Can anyone help please. I’ve also tried following the procedure for installing onto Arch Linux, which gives the same problem.
At the minute I’m trying in live mode before committing to a full install
Thank You

Installing a printer has always been one if the most difficult and irritating things for me.

My best success has been with a USB and HPLIP. I’ve never been able to set it up via wireless/network until after plugging it in first.

1 Like

I have the printer connected via usb, an trying to install hplip throws errors and fails to install

That might be because you are doing it in the live session?

By the way, what are those errors? They could give someone some ideas.

The printer should be supported with HPLIP package.

Hewlett and Packard(HP) printers:

Some of the HP-printers needs a proprietary plugin to work, this can be installed by hplip.

Here is an overview of some common printers and working drivers on Archwiki:


Most drivers for hp-printers come with the HPLIP package you can install this with:

sudo pacman -S hplip

install python-pyqt5 to run GUI and hp-toolbox:

sudo pacman -S python-pyqt5

now run the program to install new printer queue and the possibly needed proprietary plugin for some hp-printers:

sudo hp-setup -i for CLI install without a GUI

or run hp-setup from menu.

hp-setup from terminal CLI

The tool guides you through the installation – simply read the instructions.

You have your printer added now, so you do not need to set it up again as what follows, but you can use system-config-printer to setup configuration for papersize e.t.c.

you do follow this?

as @pebcak mentioned this will cause issues… and if you want to try you will need to update package database first… and do not try updating the system of the livesystem itself this will not work.

yay -Sy
yay -S hplip cups cups-filters cups-pdf system-config-printer --needed
sudo systemctl enable --now cups.service avahi

and follow what i have obove for HP printer…

but it will in no way a secure way to validate if the procedure is working… because you would need an updated system… and this could cause issues with outdated packages …

when following joekamprad, I get
Failed to enable unit: Unit file avahi.service does not exist.
this is from a full install??

you need to install that too it seems if you are still on live session… let my try that real quick…

yay -S avahi

and try again:
sudo systemctl enable --now cups.service avahi

you will need to disable the firewall also on livesession … or you need to set it up… and in case you want to setup wireless/network printing in most cases it needs local hostname resolution to be enabled…

(as wiki entry give a tutorial too)

After that I still ge
Failed to enable unit: Unit file avahi.service does not exist.t


sudo systemctl enable --now avahi-daemon.service

but i see that it is not working the same as it would on installed system… i nee dto add IP of the printer to see it in system-config-printer —
if not it will not show any network printers…

not what you should do as HP needs sudo hp-setup -i
And could be hp-setup will simply not find your printer… on the live session…

1 Like

Ok, thanks for the help, I have now installed endeavouros on my pc and successfully added the hp printer.
But system is not finding the scanner.
I’ve tried several links I googled, but they don’t make any difference, one in the forum points to a site that’s now gone.
The hp is connected via usb, is there any way to get the scanner seen ?

sry for confusion on moving… see now its you only 13 days later :wink:

so printing do work? using hp-setup from terminal?
You need to give some info on how exactly you done things if not no one can help :wink:
Error outputs e.t.c

hp-scan is the ‘HPLIP Scan Utility’. If you need that tool, you will need to install python-pillow.

yay -Syu xsane python-pillow

sudo hp-scan -i

1 Like