ACPI delaying boot

Hello!
I recently installed EOS and I’m happy with it, but yet I can’t toloerate it boots slowly for an SSD ( even slower than windows and slower than my first distros). I have encountered this in the last few distros I used, so it’s probably not a problem with eos itself (may be my hardware or bios issue, but oddly seems to affect linux only)

from inspecting boot time I found this in the output of dmesg

[    0.194178] ACPI: EC: interrupt blocked
[    3.697237] ACPI: EC: EC_CMD/EC_SC=0x66, EC_DATA=0x62

that’s about half of the kernel boot time

$ systemd-analyze

Startup finished in 7.531s (kernel) + 4.951s (userspace) = 12.483s 
graphical.target reached after 4.936s in userspace

but that’s not all, sddm takes a long time to show up, prolonging my boot time to 18-20s ( a gap between plymouth and sddm with just a blackscreen)

However, when I added acpi=off ( which is a bad idea on a laptop, was just testing) to kernel boot parameters the kernel booted up much faster (plymouth appeared instantly) and the gap between plymouth and sddm was gone (and I got the smooth transition that the arch wiki referred to), but I wasn’t able to use my keyboard or login.

I have heared of some hp devices (mine is hp zbook 17 g2) giving acpi errors on linux, but I get no errors, just a delay, twice.

So I want to decrease my boot time (the same hardware used to boot faster before.
Also, I’m using both btrfs and ext4 for my setup, my fstab, does btrfs have impact on boot?

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=f3d697c0-be62-4452-a9a9-b7a5c35d519b /boot          ext4    defaults,noatime 0 2
UUID=3a337de5-8914-46fd-8c63-acb6c00865ca /home          ext4    defaults,noatime 0 2
UUID=7a8b7149-f29e-42ce-8176-9dec51a9270f /              btrfs   subvol=/@,defaults,noatime,compress=zstd 0 0
UUID=7a8b7149-f29e-42ce-8176-9dec51a9270f /var/cache     btrfs   subvol=/@cache,defaults,noatime,compress=zstd 0 0
UUID=7a8b7149-f29e-42ce-8176-9dec51a9270f /var/log       btrfs   subvol=/@log,defaults,noatime,compress=zstd 0 0
UUID=7a8b7149-f29e-42ce-8176-9dec51a9270f /swap          btrfs   subvol=@swap                       0    0
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0
UUID=BCFE1B15FE1AC792                  /mnt/Storage      auto    nosuid,nodev,nofail,uid=1000,gid=1000,dmask=007,fmask=117,x-gvfs-show  0    0
/swap/swapfile                             none          swap    sw                                 0    0

Any help is appreciated.
Thanks.

Can you try LTS kernel?

Already using LTS kernel.