Abysmal OpenGL perfomance using Nvidia card on optimus laptop


I have this setup: i3-6006u, 16GiB RAM, Nvidia 920m (NVE0 family (Kepler)), intel hd graphics 520, ssd. And i run the latest linux-zen kernel from repos

The problem is that i want to run TF2 on linux using nvidia card, but trying to install drivers results in blurry game (like it’s being rendered at 640x480 and is upscaled afterwards) and around 10 fps on an empty map

nvidia’s site says that my card supports 430 driver from 2019 and latest 390 driver from 2021

arch wiki says: For the Kepler (NVE0) series (including GeForce 630-920) from around 2013-2014, install the nvidia-470xx-dkms(AUR) package.

What I’ve tried so far:

  1. Optimus-manager with nvidia-390xx-dkms, nvidia-470xx-dkms, nvidia-dkms (latest 495 driver). Tried to compile nvidia-430xx-dkms but COMPILATION TERMINATED.

  2. Endeavouros script nvidia-installer-dkms (link) which tells me to use it with --force and then install nvidia-390xx-dkms but it creates a dependency problem and pacman just stops the process. Tried it with -b for bumblebee but it installs 495 drivers which don’t work at all and if i install bumblebee manually with 390 it seems to run OpenGL test with optirun but TF2 won’t even start

  3. nouveau with DRI_PRIME=1, runs a bit better but 20 fps and slowmo menu is no go

Haven’t only tried nvidia-xrun yet

im sorry if this is a duplicate or something like this, i’m just really lost at this point

Try this command:

  nvidia-driver-supported-branches -a

It is in package nvidia-installer-db if you need to install it first.

This command should tell you which Nvidia driver series are supported.

NVIDIA card id: 1299
Series 495: not supported
Series 470: supported
Series 390: supported
Series 340: not supported

the problem is not that drivers don’t install, they do, it’s just that they don’t work like intended for some unknown reason

nvidia-installer-check outputs this:

Your graphics card (id: 1299) is supported by the nvidia-390xx-dkms driver.
To install a driver for this card:

  • Use the --force option with nvidia-installer-dkms.
  • Then, BEFORE rebooting, install nvidia-390xx-dkms from the AUR.
    For example:
    yay -S nvidia-390xx-dkms

and if i do this it results in:

→ nvidia-390xx-utils-390.147-1 already made – skipping build
loading packages…
resolving dependencies…
looking for conflicting packages…
:: nvidia-390xx-utils and nvidia-utils are in conflict (nvidia-libgl). Remove nvidia-utils? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing nvidia-utils breaks dependency ‘nvidia-utils=495.46’ required by nvidia-dkms
→ exit status 1

You can as well use the 470 series of Nvidia drivers.

But as the error messages say, there are conflicting packages.
That’s why you need to uninstall all conflicting Nvidia packages and install related 470 packages.

So uninstall at least

  • nvidia-dkms
  • nvidia-utils

and install

  • nvidia-470xx-dkms
  • nvidia-470xx-utils

Unfortunately the output of some commands is not fully up to date, but we are working on it.


the solution, pretty much. 470 drivers worked

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.