A unique problem with XFCE and wireplumber

Greetings EndeavourOS community,

I have encountered a very specific problem and I came here to ask for an advice on how to solve it.

I’m a relatively new user, as I made the switch about 6 months ago, and did not need much help when it came to modifying and tweaking the system to my liking until now.

I use XFCE, and the only problem I had with it is a bug that has been documented years ago but never properly fixed, I’m talking about the audio devices disconnecting every 10-15 minutes and then automatically reconnecting after 0.02 seconds more or less, this happens so fast that the only annoying thing with it was the displaying of the sound notification in the corner that I dealt with by disabling audio notifications.

This was a fine solution for about 6 months, up until the recent update, where the pipewire-media-session was replaced with wireplumber. Now when this bug occurs instead of immediately and barely noticeably reconnecting and playing the audio through the selected output, it just defaults to my speakers, with me needing to switch to the output every 10-15 minutes it has become incredibly annoying so until I figure out a fix I have switched to Cinnamon and of course it works perfectly fine and this does not happen there, but I do prefer Xfce.

So I come to you in case you have experienced a similar thing, if you have an idea for the next course of action I might take or what information I would need to provide to you in order to make your insight into this problem more clear.

Thank you for reading this.

1 Like

Never seen this happen.

Hi and welcome to the community @unhoped4!

There are many Xfce users on the forum but we haven’t had any report about this issue. Neither before nor after the switch from pipewire-media-session to wireplumber. Or before the switch to pipewire for that matter.

Also, for some background information, it would be informative if you could provide a reference to this bug documentation.

1 Like

I apologize for not providing these when I made my initial claim, these are all from different distros but it is a XFCE specific problem:


It may have been fixed in the past but the nature of it may be atavistic.

1 Like

Welcome to the forum @unhoped4 :enos_flag: :enos: :partying_face:

1 Like


A unique problem with XFCE and wireplumber

If you think this is specific to Xfce in combination with wireplumber, have you for the sake of testing switch to pipewire-media-session or just to pulseaudio altogether to see if you will be experiencing the issue then as well.


Or another desktop, XFCE isn’t the only one in the world. I mean I know it isn’t a fix…but it can stop the annoyance.


Depending on one’s hardware, it can be life-saving to use Xfce. At least sort of… in my case.

On my old Macs (11&13 yrs. of age) tending to overheat easily, I still can’t get EnOS to run on baremetal at all, while Fedora’s and MX-Linux’ latest releases do run great, although Gnome and Plasma keep overburdening the HW, so XFCE is what I have to keep using, and I’m quite happy with that!


1 Like


Welcome to the EnOS community, @unhoped4 ! :enos: :rocketa_purple: :penguin_face:

1 Like

I have already tested other desktop environments as I said in my original post and they do not exhibit this issue (Cinnamon, MATE, Budgie, Enlightenment , LXDE).

I have also switched back and forth from pipewire-media-session to wireplumber and that seems to be the crux of the issue, the bug happens with pipewire-media-session as well but it automaticly reconnects the same device after barley noticeable time frame, however wireplumber does not do so it just defaults to my speakers.

I will, however, try switching from pipewire to pulseaudio and see if the same thing persists

I’m well aware that just switching the DE would ‘‘fix’’ this problem, but I really like XFCE, it feels like home.


I use EndeavourOS regularly on two different computers WITH Xfce and I’ve never once experienced any issues, and definitely not this one.

I’ve been using EOS for approximately two years, maybe slightly longer.
Excellent stability, despite very current software. Very rare to encounter issues of any kind.

1 Like

I run XFCE, and I don’t THINK I have this problem - but I might! Sometimes when playing a youtube vid, I seem to experience a momentary disconnect/reconnect - but it is singular in nature (one time only per event/video at most) and I haven’t noticed it in any other scenario. Currently on wireplumber - but I hadn’t connected the momentary interruption with its arrival. My audio is connected through HDMI (through KVM switch to patch to powered speakers) - perhaps the destination affects things?


It seems that uninstalling pipewire-pulse and installing pulseaudio
has solved problem.

Thank you for assisting me with this, do you have any suggestions as how can I report this kind of bug to the pipewire or XFCE devs?


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.