A stop job is running for user manager for uid 1000

I will randomly get this error sometimes when rebooting and my system. There is a countdown of 2 minutes on it, which it always reaches the end of. I have looked all over and ive seen so many answers to this that dont ever seem to work (seems like it might just be happening if you dont close all applications before rebooting)

My question is: Is there a way to make this shorter? Can I change this from 2 minutes to like 10 seconds? It always runs the timer down anyway which to me sounds like it is failing to do whatever it is trying to do.

Yes, you can change it to whatever you want. Just consider the implications of doing so. If something is blocking on i/o, you may end up leaving things in an inconsistent state if you make the time too short.

The setting DefaultTimeoutStopSec is in /etc/systemd/system.conf . You may need to uncomment it.

1 Like