7800 XT extremely slow benchmark

I’ve got a new PC with an AMD 7800 XT GPU and decided to go with EOS

I see here that the 7800 XT performs well with the UNIGINE Superposition Benchmark. However when I try on the same settings it I’m getting ~5fps

To rule out hardware / hardware config issues I installed Windows To Go on a flash drive. This gives me benchmark results in a similar range to those in the Phoronix article. My hardware is good

Some information:

inxi -Faz

  Kernel: 6.5.9-arch2-1 arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: acpi_pm
    parameters: initrd=\5569f715a1f5457f9b053dcc182e9303\6.5.9-arch2-1\initrd
    nvme_load=YES nowatchdog rw
  Desktop: GNOME v: 45.0 tk: GTK v: 3.24.38 wm: gnome-shell dm: GDM
    v: 45.0.1 Distro: EndeavourOS base: Arch Linux
  Type: Mini-pc System: Intel Client Systems product: NUC13RNGi7 v: M58740-303
    serial: <superuser required> Chassis: Intel Corporation type: 35 v: 2.0
    serial: <superuser required>
  Mobo: Intel model: NUC13SBBi7 v: M89885-303 serial: <superuser required>
    UEFI: Intel v: SBRPL579.0058.2023.0817.1457 date: 08/17/2023
  Info: model: 13th Gen Intel Core i7-13700K bits: 64 type: MST AMCP
    arch: Raptor Lake gen: core 13 level: v3 note: check built: 2022+
    process: Intel 7 (10nm) family: 6 model-id: 0xB7 (183) stepping: 1
    microcode: 0x11A
  Topology: cpus: 1x cores: 16 mt: 8 tpc: 2 st: 8 threads: 24 smt: enabled
    cache: L1: 1.4 MiB desc: d-8x32 KiB, 8x48 KiB; i-8x32 KiB, 8x64 KiB
    L2: 24 MiB desc: 8x2 MiB, 2x4 MiB L3: 30 MiB desc: 1x30 MiB
  Speed (MHz): avg: 2196 high: 3898 min/max: 800/5300:5400:4200 scaling:
    driver: intel_pstate governor: powersave cores: 1: 1466 2: 2692 3: 2537
    4: 800 5: 2794 6: 800 7: 3674 8: 800 9: 3391 10: 2877 11: 3797 12: 3800
    13: 3692 14: 3272 15: 2298 16: 800 17: 3898 18: 800 19: 800 20: 2714
    21: 800 22: 2613 23: 800 24: 800 bogomips: 164088
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced / Automatic IBRS, IBPB:
    conditional, RSB filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Navi 32 [Radeon RX 7700 XT / 7800 XT] driver: amdgpu v: kernel
    pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: DP-1
    empty: DP-2,HDMI-A-1,HDMI-A-2 bus-ID: 03:00.0 chip-ID: 1002:747e
    class-ID: 0300
  Display: wayland server: X.org v: with: Xwayland v: 23.2.2
    compositor: gnome-shell driver: X: loaded: amdgpu
    unloaded: modesetting,radeon alternate: fbdev,vesa dri: radeonsi
    gpu: amdgpu display-ID: 0
  Monitor-1: DP-1 model: LG (GoldStar) ULTRAWIDE serial: <filter>
    built: 2023 res: 3840x1080 dpi: 81 gamma: 1.2
    size: 1198x337mm (47.17x13.27") diag: 1244mm (49") modes: max: 5120x1440
    min: 640x480
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
    device: 1 drv: swrast surfaceless: drv: radeonsi wayland: drv: radeonsi x11:
    drv: radeonsi inactive: gbm
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.2.1-arch1.2
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 7800 XT (gfx1101 LLVM
    16.0.6 DRM 3.54 6.5.9-arch2-1) device-ID: 1002:747e memory: 15.62 GiB
    unified: no display-ID: :0.0
  API: Vulkan v: 1.3.269 layers: 7 device: 0 type: discrete-gpu name: AMD
    Radeon RX 7800 XT (RADV GFX1101) driver: mesa radv v: 23.2.1-arch1.2
    device-ID: 1002:747e surfaces: xcb,xlib,wayland
  Device-1: Intel Alder Lake-S HD Audio vendor: Realtek driver: snd_hda_intel
    v: kernel alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:7ad0 class-ID: 0401
  Device-2: AMD Navi 31 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 03:00.1 chip-ID: 1002:ab30
    class-ID: 0403
  Device-3: Realtek [] driver: hid-generic,snd-usb-audio,usbhid type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-8:5 chip-ID: 0bda:4c60
    class-ID: 0300
  API: ALSA v: k6.5.9-arch2-1 status: kernel-api
    tools: alsactl,alsamixer,amixer
  Server-1: PipeWire v: 0.3.83 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Alder Lake-S PCH CNVi WiFi vendor: Rivet Networks
    driver: iwlwifi v: kernel bus-ID: 00:14.3 chip-ID: 8086:7af0 class-ID: 0280
  IF: wlan0 state: down mac: <filter>
  Device-2: Aquantia AQC113C NBase-T/IEEE 802.3bz Ethernet [AQtion]
    vendor: Intel driver: atlantic v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 2
    port: N/A bus-ID: 05:00.0 chip-ID: 1d6a:14c0 class-ID: 0200 temp: 69.0 C
  IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-3: Intel Ethernet I226-V driver: igc v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 port: N/A bus-ID: 06:00.0 chip-ID: 8086:125c
    class-ID: 0200
  IF: enp6s0 state: down mac: <filter>
  IF-ID-1: virbr0 state: down mac: <filter>
  Device-1: Intel [] driver: btusb v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 1-14:6 chip-ID: 8087:0033 class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: <filter> bt-v: 5.3 lmp-v: 12
    status: discoverable: no pairing: no
  Local Storage: total: 2.75 TiB used: 618.27 GiB (21.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: solidgm model: SSDPFKKW010X7
    size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 001C temp: 53.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: WDC WDS200T2B0A-00SM50
    size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 40WD scheme: GPT
  ID-1: / raw-size: 952.88 GiB size: 936.85 GiB (98.32%)
    used: 165.68 GiB (17.7%) fs: ext4 dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-7708eb51-7038-4bf1-85b8-773406342ab8
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: zram size: 10.31 GiB used: 0 KiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 24 dev: /dev/zram0
  System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 42.0 C mem: 57.0 C
  Fan Speeds (rpm): N/A gpu: amdgpu fan: 17
  Processes: 753 Uptime: 2m wakeups: 2 Memory: total: 32 GiB note: est.
  available: 30.92 GiB used: 5.21 GiB (16.9%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: 1394 pm: pacman pkgs: 1347 libs: 418
  tools: gnome-software,pamac,yay pm: flatpak pkgs: 47 Shell: Bash v: 5.1.16
  running-in: flatpak-session inxi: 3.3.30

lspci -k | grep -A 3 -E “(VGA|3D)”

03:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Navi 32 [Radeon RX 7700 XT / 7800 XT] (rev c8)
	Kernel driver in use: amdgpu
	Kernel modules: amdgpu
03:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Navi 31 HDMI/DP Audio

pacman -Qs linux-firmware

local/linux-firmware 20230804.7be2766d-2
    Firmware files for Linux
local/linux-firmware-whence 20230804.7be2766d-2
    Firmware files for Linux - contains the WHENCE license file which documents the vendor license details

pacman -Qs vulkan

local/gpu-viewer 2.30-1
    A frontend to glxinfo and vulkaninfo.
local/lib32-vulkan-icd-loader 1.3.269-1
    Vulkan Installable Client Driver (ICD) Loader (32-bit)
local/lib32-vulkan-intel 1:23.2.1-2
    Intel's Vulkan mesa driver (32-bit)
local/lib32-vulkan-mesa-layers 1:23.2.1-2
    Mesa's Vulkan layers (32-bit)
local/lib32-vulkan-radeon 1:23.2.1-2
    Radeon's Vulkan mesa driver (32-bit)
local/spirv-tools 2022.4-1 (vulkan-devel)
    API and commands for processing SPIR-V modules
local/vulkan-headers 1:1.3.269-1 (vulkan-devel)
    Vulkan header files
local/vulkan-icd-loader 1.3.269-1
    Vulkan Installable Client Driver (ICD) Loader
local/vulkan-intel 1:23.2.1-2
    Intel's Vulkan mesa driver
local/vulkan-mesa-layers 1:23.2.1-2
    Mesa's Vulkan layers
local/vulkan-radeon 1:23.2.1-2
    Radeon's Vulkan mesa driver
local/vulkan-tools 1.3.269-1 (vulkan-devel)
    Vulkan Utilities and Tools

pacman -Qs mesa

local/glu 9.0.3-1
    Mesa OpenGL utility library
local/lib32-libva-mesa-driver 1:23.2.1-2
    VA-API drivers (32-bit)
local/lib32-mesa 1:23.2.1-2
    An open-source implementation of the OpenGL specification (32-bit)
local/lib32-mesa-vdpau 1:23.2.1-2
    VDPAU drivers (32-bit)
local/lib32-vulkan-intel 1:23.2.1-2
    Intel's Vulkan mesa driver (32-bit)
local/lib32-vulkan-mesa-layers 1:23.2.1-2
    Mesa's Vulkan layers (32-bit)
local/lib32-vulkan-radeon 1:23.2.1-2
    Radeon's Vulkan mesa driver (32-bit)
local/libva-mesa-driver 1:23.2.1-2
    VA-API drivers
local/mesa 1:23.2.1-2
    An open-source implementation of the OpenGL specification
local/mesa-utils 9.0.0-3
    Essential Mesa utilities
local/vulkan-intel 1:23.2.1-2
    Intel's Vulkan mesa driver
local/vulkan-mesa-layers 1:23.2.1-2
    Mesa's Vulkan layers
local/vulkan-radeon 1:23.2.1-2
    Radeon's Vulkan mesa driver

vulkaninfo --summary


Vulkan Instance Version: 1.3.269

Instance Extensions: count = 23
VK_EXT_acquire_drm_display             : extension revision 1
VK_EXT_acquire_xlib_display            : extension revision 1
VK_EXT_debug_report                    : extension revision 10
VK_EXT_debug_utils                     : extension revision 2
VK_EXT_direct_mode_display             : extension revision 1
VK_EXT_display_surface_counter         : extension revision 1
VK_EXT_surface_maintenance1            : extension revision 1
VK_EXT_swapchain_colorspace            : extension revision 4
VK_KHR_device_group_creation           : extension revision 1
VK_KHR_display                         : extension revision 23
VK_KHR_external_fence_capabilities     : extension revision 1
VK_KHR_external_memory_capabilities    : extension revision 1
VK_KHR_external_semaphore_capabilities : extension revision 1
VK_KHR_get_display_properties2         : extension revision 1
VK_KHR_get_physical_device_properties2 : extension revision 2
VK_KHR_get_surface_capabilities2       : extension revision 1
VK_KHR_portability_enumeration         : extension revision 1
VK_KHR_surface                         : extension revision 25
VK_KHR_surface_protected_capabilities  : extension revision 1
VK_KHR_wayland_surface                 : extension revision 6
VK_KHR_xcb_surface                     : extension revision 6
VK_KHR_xlib_surface                    : extension revision 6
VK_LUNARG_direct_driver_loading        : extension revision 1

Instance Layers: count = 7
VK_LAYER_INTEL_nullhw             INTEL NULL HW                1.1.73   version 1
VK_LAYER_MESA_device_select       Linux device selection layer 1.3.211  version 1
VK_LAYER_MESA_overlay             Mesa Overlay layer           1.3.211  version 1
VK_LAYER_VALVE_steam_fossilize_32 Steam Pipeline Caching Layer 1.3.207  version 1
VK_LAYER_VALVE_steam_fossilize_64 Steam Pipeline Caching Layer 1.3.207  version 1
VK_LAYER_VALVE_steam_overlay_32   Steam Overlay Layer          1.3.207  version 1
VK_LAYER_VALVE_steam_overlay_64   Steam Overlay Layer          1.3.207  version 1

	apiVersion         = 1.3.255
	driverVersion      = 23.2.1
	vendorID           = 0x1002
	deviceID           = 0x747e
	deviceName         = AMD Radeon RX 7800 XT (RADV GFX1101)
	driverID           = DRIVER_ID_MESA_RADV
	driverName         = radv
	driverInfo         = Mesa 23.2.1-arch1.2
	conformanceVersion =
	deviceUUID         = 00000000-0300-0000-0000-000000000000
	driverUUID         = 414d442d-4d45-5341-2d44-525600000000

sudo dmesg : http://ix.io/4Khk

modprobe --showconfig | grep blacklist

blacklist radeon

pacman -Q unigine-superposition

unigine-superposition 1.1-6

Things I’ve tried with no improvement


aur/linux-firmware-git 20230814.0e048b06-1

amdvlk-2023.Q4.1-1, lib32-amdvlk-2023.Q4.1-1

I attempted to try mesa-git but got:

error: failed to prepare transaction (could not satisfy dependencies)

One thing that I’ve noticed is that when I do cat pp_dpm_sclk I get

0: 500Mhz
1: 41Mhz *
2: 2124Mhz

Is that in the wrong order? Everything I read online shows those numbers increasing as the identifier increases

Also when I use extra/corectrl 1.3.6-1 the Power never seems to go above ~25-30W and the Memory 96Mhz

While running the benchmark the temp stays well under 50C and the fans never spin up

I’ve run out of ideas. Can anyone here please help?

To add. This is the card, I believe it only has a single BIOS


You have fantastic hardware.
Just a curiosity of mine (no harm intended); do you have a minimum 700 watts power supply connected to it ?
Resize bar is activated in BIOS ?

Thanks! My previous desktop was bought in Feb 2016 so I’ve been well overdue for an upgrade

The PSU is 750W 80+ Gold and the docs specifically say that the machine “supports up to ~450W, 313mm length, triple-slot cards

Resize bar is activated in BIOS. As I mentioned - this works fine on a Windows To Go flash drive

OK good.
I was asking because your 7800 web documentation was mentioning a minimum 700 watts.
So all hardware is to specs.

What is the refresh rate of your monitor set to?

Someone recently reported an issue on current gen AMD cards where if the refresh rate was set above 144Hz, it was artificially lowering clock speeds.

You also might considering removing all those intel drivers.

sudo pacman -Rns lib32-vulkan-intel vulkan-intel

Linux-firmware updated today to linux-firmware 20230918.3672ccab-1

Refresh rate set to highest for this monitor - 144Hz

Rebooted - still have the same problem

To update I’ve tried amdgpu.aspm=0 with no noticeable effect

I’ve also tried amdgpu.dc=0 which leaves me with a blank screen

Anyone have any other ideas?

Now tried mesa-git 1:24.0.0_devel.179915.d67d501af46-1 with no difference