2023_Slow start up with KDE Plasma and SDDM, Many TTY instances

I tried to necro bump and old thread with a very similar problem, but different and the fixes in that thread didn’t do anything noteworthy.

When I,

systemd-analyzeStartup finished in 29.120s (firmware) + 3.368s (loader) + 1.165s (kernel) + 766ms (initrd) + 2.245s (userspace) = 36.667s
graphical.target reached after 2.244s in userspace.

When I,

systemd-analyse blame

1.195s dev-ttyS30.device
1.195s sys-devices-platform-serial8250-tty-ttyS30.device
1.194s dev-ttyS31.device
1.194s sys-devices-platform-serial8250-tty-ttyS31.device
1.194s dev-ttyS29.device
1.194s sys-devices-platform-serial8250-tty-ttyS29.device
1.193s sys-devices-platform-serial8250-tty-ttyS5.device
1.193s dev-ttyS5.device
1.192s dev-ttyS6.device
1.192s sys-devices-platform-serial8250-tty-ttyS6.device
1.192s sys-devices-platform-serial8250-tty-ttyS3.device
1.192s dev-ttyS3.device
1.192s sys-devices-platform-serial8250-tty-ttyS4.device
1.192s dev-ttyS4.device
1.192s dev-ttyS9.device
1.192s sys-devices-platform-serial8250-tty-ttyS9.device
1.192s dev-ttyS8.device
1.192s sys-devices-platform-serial8250-tty-ttyS8.device
1.191s sys-devices-platform-serial8250-tty-ttyS7.device
1.191s dev-ttyS7.device
1.164s dev-ttyS0.device
1.164s sys-devices-platform-serial8250-tty-ttyS0.device
1.164s sys-devices-platform-serial8250-tty-ttyS1.device
1.164s dev-ttyS1.device
1.164s sys-devices-platform-serial8250-tty-ttyS12.device
1.164s dev-ttyS12.device
1.163s dev-ttyS14.device
1.163s sys-devices-platform-serial8250-tty-ttyS14.device
1.163s sys-devices-platform-serial8250-tty-ttyS10.device
1.163s dev-ttyS10.device
1.162s sys-devices-platform-serial8250-tty-ttyS16.device
1.162s dev-ttyS16.device
1.162s dev-ttyS15.device
1.162s sys-devices-platform-serial8250-tty-ttyS15.device
1.162s dev-ttyS11.device
1.162s sys-devices-platform-serial8250-tty-ttyS11.device
1.162s dev-ttyS13.device
1.162s sys-devices-platform-serial8250-tty-ttyS13.device
1.162s sys-devices-platform-serial8250-tty-ttyS17.device
1.162s dev-ttyS17.device
1.162s dev-ttyS2.device
1.162s sys-devices-platform-serial8250-tty-ttyS2.device
1.162s sys-devices-platform-serial8250-tty-ttyS20.device
1.162s dev-ttyS20.device
1.161s dev-ttyS21.device
1.161s sys-devices-platform-serial8250-tty-ttyS21.device
1.161s dev-ttyS23.device
1.161s sys-devices-platform-serial8250-tty-ttyS23.device
1.161s dev-ttyS18.device
1.161s sys-devices-platform-serial8250-tty-ttyS18.device
1.161s sys-module-configfs.device
1.160s dev-ttyS22.device
1.160s sys-devices-platform-serial8250-tty-ttyS22.device
1.160s sys-devices-platform-serial8250-tty-ttyS26.device
1.160s dev-ttyS26.device
1.160s dev-ttyS19.device
1.160s sys-devices-platform-serial8250-tty-ttyS19.device
1.160s dev-ttyS27.device
1.160s sys-devices-platform-serial8250-tty-ttyS27.device
1.160s dev-ttyS25.device
1.160s sys-devices-platform-serial8250-tty-ttyS25.device
lines 1-61…skipping…
1.195s dev-ttyS30.device
1.195s sys-devices-platform-serial8250-tty-ttyS30.device
1.194s dev-ttyS31.device
1.194s sys-devices-platform-serial8250-tty-ttyS31.device

There is a few pages of that and then it relates to my disks,
being numerous entries with similar times as the TTY entries shown.

I was also having issues with log-screen-ception, a log screen within a log screen!
I got over this by forcing all instances of me to sign out.
Before that i was using TTY to do other things, so not sure if I caused it or not.
I think I reinstalled SDDM again around this time too.

There was a time when it would boot about as fast as lightdm.

Web’s most relevant result was the old thread on EOS forum that I tried to necro 3 days ago.

I tried masking many of the TTY services and devices and that seemed helped a little.

I picked up the command…
journalctl -b -p err
and found that SDDM was stalling because it couldn’t find my wallpaper, once I changed it to a stock item, that it seemed to be back to the <5second load I knew it was capable of.

I did install the full KDE desktop before I noticed it was working fine again, so it may have been that, but I think it was the wallpaper not loading.

I plan to hunt down the source of the many remaining TTY items and either mask them or change their config to run less.
I already did the obvious .config to no avail.

I think i need to compile/recompile the kernel though, something that I would have to learn, so perhaps not right now.

wonka 2

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.