0 updates mention with only AUR updates

I just had this message:
0updates

I had AUR updates, but that seems not counted.

can you more clear, which packagemanager ?

yay -Qua ?

I have no idea, I used the Update System option from Welcome.

Have you updated your system with sudo pacman -Syyu or yay -Syyu lately ?

Is it an automatic update notification, or do you manually check updates in Welcome?

After the automatic update notification, I manually checked for updates in the Welcome app, and then the notification in the opening post appeared while updating the apps in the AUR.

Do you mean both update procedures were working at the same time?

In order to replicate and fix this issue I need more information.

Which application were you using? Welcome does not have update notifications.
Were you using two different update programs at the same time?
Show exactly what happened, and what commands you gave, and when.

I believe what he is saying is he gets the eos update notifier message and then goes to the welcome app and clicks the update system button from there.

I too recently noticed the eos update notifier say 0 AUR updates are available. But I just ignored it.

They are not designed to be run at the same time. Naturally they are protected not to mess up updates, but if one notifies about updates and the other does the update, the first doesn’t know that.

So the advice is not to use more than one updating program at the same time.

I thought the update was done fine. I was just amazed at this EOS update notification that 0 AUR updates are available.

With this information, that is something I can’t replicate here.

I use both apps. No problem, because the EOS update notification can be ignored.

Perhaps I can add some more info.

I recently got this same message, I then went to pamac-aur (With check for AUR updates enabled) and checked for updates, I had one for package pamac-aur pending from the AUR.

It seems that while eos update notifier did know there were AUR updates pending it didn’t count them correctly.

2 Likes

So far, I have not received any notification with this content. This is the first time this has happened.

That could explain this behavior!

I just changed eos-update-notifier to version 1.8.7-1 and it has a fix to this issue.

If someone could be so kind to test that it works there, that would really help! :smile:

I see sometimes that updates message appearing automatically without me doing anything, and after that I use Update System in Welcome, I never use sudo pacman -Syyu or yay -Syyu.

Can you show your config file /etc/eos-update-notifier.conf ?

Note that the eos-update-notifier can also do the real updating process, so Welcome’s update is not strictly needed.

eos-update-notifier configuration file

Check also updates from AUR:

CheckAurUpdates=yes # yes or no

Check also Arch news for you:

CheckArchNewsForYou=yes # yes or no

Check news while updating?

AllowNewsCheckWhileUpdating=yes # yes or no

Alternative programs for showing the Arch news. Select one.

Note: ‘arch-news-for-you’ uses an ad hoc way to determine if the news are

relevant to your machine. This mostly works well, but not always.

The ‘eos-arch-news’ shows news based on the date and shows only news

that are not yet shown.

This option was added in eos-update-notifier version 0.9-1.

ArchNewsProg=eos-arch-news # values: ‘eos-arch-news’ or ‘arch-news-for-you’

Prefer tray notification or small window for nofitying about updates?

NOTE: if clicking the tray notification icon launches also the next panel item,

a workaround is either to

- re-organize panel’s notification area icons so that ‘Yad’ is not the first (uppermost), or

- add an empty launcher right next to the tray notification icon.

ShowHowAboutUpdates=notify # value: ‘notify’, ‘notify+tray’, ‘tray’, or ‘window’

What info to show about pending updates (“number of updates” or “package names”);

applies only when ‘ShowHowAboutUpdates’ is set to ‘window’:

ShowWhatAboutUpdates=number # values: ‘number’ or ‘packages’

Thanks!

I hope the latest change to eos-update-notifier fixed this problem.
Please inform me about the result! :smile:

1 Like